aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ofono
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2015-10-09 06:49:23 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2015-10-09 06:49:23 +0000
commit0b0f30dbfb3a37ff07e296da09b5d12ad2e08824 (patch)
tree6d8aa1c579a094b7536e6b3fb8ea926b70307440 /testing/ofono
parenta4571868b71a0066db30a30c157acdc1bc33e218 (diff)
downloadaports-0b0f30dbfb3a37ff07e296da09b5d12ad2e08824.tar.bz2
aports-0b0f30dbfb3a37ff07e296da09b5d12ad2e08824.tar.xz
testing/ofono: added initd, changed path to /usr/sbin
Diffstat (limited to 'testing/ofono')
-rw-r--r--testing/ofono/APKBUILD17
-rw-r--r--testing/ofono/ofono.initd20
2 files changed, 31 insertions, 6 deletions
diff --git a/testing/ofono/APKBUILD b/testing/ofono/APKBUILD
index 603675e4d5..e55a912eac 100644
--- a/testing/ofono/APKBUILD
+++ b/testing/ofono/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=ofono
pkgver=1.17
-pkgrel=0
+pkgrel=1
pkgdesc="Infrastructure for building mobile telephony (GSM/UMTS) applications"
url="https://01.org/ofono"
arch="all"
@@ -12,7 +12,8 @@ depends_dev="glib-dev dbus-dev eudev-dev linux-headers bsd-compat-headers libexe
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://www.kernel.org/pub/linux/network/$pkgname/$pkgname-$pkgver.tar.xz"
+source="https://www.kernel.org/pub/linux/network/$pkgname/$pkgname-$pkgver.tar.xz
+ $pkgname.initd"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
local i
@@ -30,15 +31,19 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --sbindir=/usr/bin
+ --sbindir=/usr/sbin
make || return 1
}
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
+ install -Dm755 "$srcdir/$pkgname.initd" "$pkgdir/etc/init.d/$pkgname"
}
-md5sums="d280b1d267ba5bf391d2a898fea7c748 ofono-1.17.tar.xz"
-sha256sums="cbf20f07fd15253c682b23c1786d517f505c3688f7c4ea93da777e1523b89635 ofono-1.17.tar.xz"
-sha512sums="d945c87b9c759b459926fcc002d4fb6938c5359a0070a0c623da9f98e342fd2bd92a5f4f22a14e4aa66b5cb3467c3d8f09a95d991ced0b774c066a6406d0746c ofono-1.17.tar.xz"
+md5sums="d280b1d267ba5bf391d2a898fea7c748 ofono-1.17.tar.xz
+d159d86d4d6e37b1b2392ea763132091 ofono.initd"
+sha256sums="cbf20f07fd15253c682b23c1786d517f505c3688f7c4ea93da777e1523b89635 ofono-1.17.tar.xz
+539925e3caa989bb5a40397406ab4afc893a7fa70bc9ff3bd8fd59fb54ac084c ofono.initd"
+sha512sums="d945c87b9c759b459926fcc002d4fb6938c5359a0070a0c623da9f98e342fd2bd92a5f4f22a14e4aa66b5cb3467c3d8f09a95d991ced0b774c066a6406d0746c ofono-1.17.tar.xz
+7f17143545e1a229254b34da76a449d2c1dea238ee988d606de1a12a54fe691cd946f73e446ae786624abbcdc539338334c1d3b0d1e49fdd8ba8ba6aa51b15ff ofono.initd"
diff --git a/testing/ofono/ofono.initd b/testing/ofono/ofono.initd
new file mode 100644
index 0000000000..517b3a2b11
--- /dev/null
+++ b/testing/ofono/ofono.initd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Purpose License v2
+# $Header: ./gentoo-x86-cvsroot/net-misc/ofono/files/ofono.initd,v 1.1 2009/08/24 13:20:40 dagger Exp $
+
+depend() {
+ need dbus
+}
+
+start() {
+ ebegin "Starting oFono"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ofonod
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping oFono"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ofonod
+ eend $?
+}