aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openmpi
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2016-11-15 16:46:43 -0500
committerDaniel Sabogal <dsabogalcc@gmail.com>2016-11-15 16:46:43 -0500
commitc3a22941a44aa1e9fa36cf8a15f32e1b75e4e73c (patch)
treeb26d03c60ab4ccfd2c07237a702ae7186bda743b /testing/openmpi
parent0e4fc53ee46c8401d8773c04ae9046d98788444c (diff)
downloadaports-c3a22941a44aa1e9fa36cf8a15f32e1b75e4e73c.tar.bz2
aports-c3a22941a44aa1e9fa36cf8a15f32e1b75e4e73c.tar.xz
testing/openmpi: new aport
https://www.open-mpi.org/ Message passing library for high-performance computing
Diffstat (limited to 'testing/openmpi')
-rw-r--r--testing/openmpi/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/openmpi/APKBUILD b/testing/openmpi/APKBUILD
new file mode 100644
index 0000000000..1a131d8d79
--- /dev/null
+++ b/testing/openmpi/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer:
+pkgname=openmpi
+pkgver=2.0.1
+pkgrel=0
+pkgdesc="Message passing library for high-performance computing"
+url="https://www.open-mpi.org/"
+arch="all"
+license="BSD"
+depends=""
+makedepends="perl hwloc-dev libgomp"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://www.open-mpi.org/software/ompi/v${pkgver%.*}/downloads/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/$pkgname \
+ --enable-ipv6 \
+ --with-threads=posix \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="6f78155bd7203039d2448390f3b51c96 openmpi-2.0.1.tar.bz2"
+sha256sums="fed74f4ae619b7ebcc18150bb5bdb65e273e14a8c094e78a3fea0df59b9ff8ff openmpi-2.0.1.tar.bz2"
+sha512sums="161cb2ab9dcf9cca3928acac6f6294c957a69d1314e8e749b36a26e21d231eda4ffc2636e3122a8dbf93a1da6077a15a079bf3643ea220a3cf060cfa923f5aed openmpi-2.0.1.tar.bz2"