aboutsummaryrefslogtreecommitdiffstats
path: root/testing/opensc/libressl.patch
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-10-19 09:05:40 +0300
committerTimo Teräs <timo.teras@iki.fi>2016-10-19 09:06:04 +0300
commiteead0b601d355faae2d7169afc8088ca631fb33e (patch)
treeb505eefcd9aa7e3688aa7a368973a598b7c18761 /testing/opensc/libressl.patch
parent3678eef246acbeb90bf32f32fb052373897a32ca (diff)
downloadaports-eead0b601d355faae2d7169afc8088ca631fb33e.tar.bz2
aports-eead0b601d355faae2d7169afc8088ca631fb33e.tar.xz
testing/opensc: upgrade to 0.16.0, fix libressl issue
- libressl fix from void linux patches
Diffstat (limited to 'testing/opensc/libressl.patch')
-rw-r--r--testing/opensc/libressl.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/testing/opensc/libressl.patch b/testing/opensc/libressl.patch
new file mode 100644
index 0000000000..003328e000
--- /dev/null
+++ b/testing/opensc/libressl.patch
@@ -0,0 +1,22 @@
+https://raw.githubusercontent.com/voidlinux/void-packages/4b22d402a290a6192853dd3994e24128023a3b7e/srcpkgs/opensc/patches/libressl.patch
+
+--- a/src/pkcs11/openssl.c.orig 2016-06-05 18:51:11.947157265 +0200
++++ b/src/pkcs11/openssl.c 2016-06-05 18:55:21.067170117 +0200
+@@ -180,7 +180,7 @@
+ e = ENGINE_by_id("gost");
+ if (!e)
+ {
+-#if !defined(OPENSSL_NO_STATIC_ENGINE) && !defined(OPENSSL_NO_GOST)
++#if !defined(LIBRESSL_VERSION_NUMBER) && !defined(OPENSSL_NO_STATIC_ENGINE) && !defined(OPENSSL_NO_GOST)
+ ENGINE_load_gost();
+ e = ENGINE_by_id("gost");
+ #else
+@@ -195,7 +195,7 @@
+ ENGINE_free(e);
+ e = NULL;
+ }
+-#endif /* !OPENSSL_NO_STATIC_ENGINE && !OPENSSL_NO_GOST */
++#endif /* !defined(LIBRESSL_VERSION_NUMBER) && !defined(OPENSSL_NO_STATIC_ENGINE) && !defined(OPENSSL_NO_GOST) */
+ }
+ if (e) {
+ ENGINE_set_default(e, ENGINE_METHOD_ALL);