aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openscenegraph
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-06-27 12:05:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-30 16:28:10 +0000
commit2b1b68faae506777d1bca6f9d6a2227e005fc357 (patch)
tree3da5d6d246d8f8060ae2a46337584fc9a82e027a /testing/openscenegraph
parent4c9c96addb1935adfcc9dcbc609c0c9a99477a6b (diff)
downloadaports-2b1b68faae506777d1bca6f9d6a2227e005fc357.tar.bz2
aports-2b1b68faae506777d1bca6f9d6a2227e005fc357.tar.xz
testing/openscenegraph: fix build on ppc64le
Add missing include for string.h, that was not been included for ppc64le
Diffstat (limited to 'testing/openscenegraph')
-rw-r--r--testing/openscenegraph/APKBUILD6
-rw-r--r--testing/openscenegraph/add-missing-include-for-ppc64le.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/testing/openscenegraph/APKBUILD b/testing/openscenegraph/APKBUILD
index c7a101c149..56bb2b3dcc 100644
--- a/testing/openscenegraph/APKBUILD
+++ b/testing/openscenegraph/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.4.0
pkgrel=5
pkgdesc="High performance 3D graphics toolkit"
url="https://openscenegraph.org"
-arch="all !ppc64le"
+arch="all"
license="Custom"
depends=
depends_dev=
@@ -15,6 +15,7 @@ subpackages="$pkgname-dev $pkgname-doc"
source="http://trac.openscenegraph.org/downloads/developer_releases/OpenSceneGraph-$pkgver.zip
musl-fixes.patch
replace-deprecated-FFmpeg-API-to-fix-build-with-ffmp.patch
+ add-missing-include-for-ppc64le.patch
"
builddir="$srcdir"/OpenSceneGraph-$pkgver
@@ -41,4 +42,5 @@ package() {
sha512sums="b598a7d68c9e5bf840d7b0a59a334037c3b6efe4d2dce333280b63a8ccef1b9a37cd5ff32b98f18e110ff9cbc48226f588e143cb1d68405edda3c60ab2f3f73a OpenSceneGraph-3.4.0.zip
016b09874bd6ca14cf1dba9274df4fc0413d2d97c3438135ecf6c5726029963f1ff279eb4986afe86173739512799e1e8ee5f7443e30fe1131524405a9d002be musl-fixes.patch
-8fa606d29ff7f45b9ada05482f61f99541d6b7803ba2fcb1d82c2b4c4045db7706334075a90a100cad5b9c1e25d290c4be6899fb12b36593e004b830cf1bdb64 replace-deprecated-FFmpeg-API-to-fix-build-with-ffmp.patch"
+8fa606d29ff7f45b9ada05482f61f99541d6b7803ba2fcb1d82c2b4c4045db7706334075a90a100cad5b9c1e25d290c4be6899fb12b36593e004b830cf1bdb64 replace-deprecated-FFmpeg-API-to-fix-build-with-ffmp.patch
+a3e69609b2e3c51002f4babd1c5bd64fc9c32b14fc9232f4b4f345c6e96134bc80a0fe54ce3445059b4d0512d5ac1ec434101fe976b71f24c68b3569265e21d9 add-missing-include-for-ppc64le.patch"
diff --git a/testing/openscenegraph/add-missing-include-for-ppc64le.patch b/testing/openscenegraph/add-missing-include-for-ppc64le.patch
new file mode 100644
index 0000000000..8731b33a88
--- /dev/null
+++ b/testing/openscenegraph/add-missing-include-for-ppc64le.patch
@@ -0,0 +1,13 @@
+--- OpenSceneGraph-3.4.0/src/OpenThreads/pthreads/PThread.cpp
++++ OpenSceneGraph-3.4.0/src/OpenThreads/pthreads/PThread.cpp
+@@ -57,6 +57,10 @@
+
+ #include <iostream>
+
++#ifdef __powerpc64__
++#include <string.h>
++#endif
++
+ using namespace OpenThreads;
+
+ #ifdef DEBUG