aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openscenegraph
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-01-05 11:40:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-01-05 11:40:08 +0000
commit3a1dbb3948aaeb805f4d222a4891d0f4bebd950d (patch)
tree1d9e704ba7590024711305838c097fe2ef7cc4db /testing/openscenegraph
parent48ea25ac108d231512a0d6ccf6301025b0401057 (diff)
downloadaports-3a1dbb3948aaeb805f4d222a4891d0f4bebd950d.tar.bz2
aports-3a1dbb3948aaeb805f4d222a4891d0f4bebd950d.tar.xz
testing/openscenegraph: fix build with arm and aarch64
Diffstat (limited to 'testing/openscenegraph')
-rw-r--r--testing/openscenegraph/APKBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/testing/openscenegraph/APKBUILD b/testing/openscenegraph/APKBUILD
index 3dc903e2ff..bc1341db7f 100644
--- a/testing/openscenegraph/APKBUILD
+++ b/testing/openscenegraph/APKBUILD
@@ -4,7 +4,7 @@ pkgver=3.4.0
pkgrel=1
pkgdesc="High performance 3D graphics toolkit"
url="https://openscenegraph.org"
-arch="x86 x86_64"
+arch="all"
license="Custom"
depends=
depends_dev=
@@ -20,7 +20,10 @@ builddir="$srcdir"/OpenSceneGraph-$pkgver
prepare() {
cd "$builddir"
default_prepare || return 1
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release || return 1
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-narrowing" \
+ || return 1
}
build() {