aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openscenegraph
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-01-01 12:37:05 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-01-01 12:37:52 +0000
commit40f16916072f70bb59b15390136f6a2f781e1348 (patch)
tree0f25760b5c7aad1f6805c71a673e640bcb5686e2 /testing/openscenegraph
parentbeaec09a2d6913cf0f74897d968c645a5a92819b (diff)
downloadaports-40f16916072f70bb59b15390136f6a2f781e1348.tar.bz2
aports-40f16916072f70bb59b15390136f6a2f781e1348.tar.xz
testing/openscenegraph: upgrade to 3.4.1
Diffstat (limited to 'testing/openscenegraph')
-rw-r--r--testing/openscenegraph/APKBUILD27
-rw-r--r--testing/openscenegraph/replace-deprecated-FFmpeg-API-to-fix-build-with-ffmp.patch176
2 files changed, 10 insertions, 193 deletions
diff --git a/testing/openscenegraph/APKBUILD b/testing/openscenegraph/APKBUILD
index 56bb2b3dcc..7dab4e7f97 100644
--- a/testing/openscenegraph/APKBUILD
+++ b/testing/openscenegraph/APKBUILD
@@ -1,46 +1,39 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=openscenegraph
-pkgver=3.4.0
-pkgrel=5
+pkgver=3.4.1
+pkgrel=0
pkgdesc="High performance 3D graphics toolkit"
url="https://openscenegraph.org"
arch="all"
-license="Custom"
-depends=
-depends_dev=
+license="Custom wxWindows-3 LGPL-2.1"
makedepends="$depends_dev cmake mesa-dev jasper-dev curl-dev giflib-dev zlib-dev
freetype-dev jpeg-dev tiff-dev sdl-dev sdl2-dev libxml2-dev gdal-dev"
-install=
subpackages="$pkgname-dev $pkgname-doc"
-source="http://trac.openscenegraph.org/downloads/developer_releases/OpenSceneGraph-$pkgver.zip
+source="https://github.com/openscenegraph/OpenSceneGraph/archive/OpenSceneGraph-$pkgver.tar.gz
musl-fixes.patch
- replace-deprecated-FFmpeg-API-to-fix-build-with-ffmp.patch
add-missing-include-for-ppc64le.patch
"
-builddir="$srcdir"/OpenSceneGraph-$pkgver
+builddir="$srcdir"/OpenSceneGraph-OpenSceneGraph-$pkgver
prepare() {
- cd "$builddir"
- default_prepare || return 1
+ default_prepare
cmake . -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-narrowing" \
- || return 1
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS -Wno-narrowing"
}
build() {
cd "$builddir"
- make || return 1
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
install -D -m644 LICENSE.txt "$pkgdir/usr/share/doc/$pkgname/LICENSE"
[ -d "$pkgdir/usr/lib64" ] && mv "$pkgdir/usr/lib64" "$pkgdir/usr/lib" || true
}
-sha512sums="b598a7d68c9e5bf840d7b0a59a334037c3b6efe4d2dce333280b63a8ccef1b9a37cd5ff32b98f18e110ff9cbc48226f588e143cb1d68405edda3c60ab2f3f73a OpenSceneGraph-3.4.0.zip
+sha512sums="4a65625e208d24256b5564bbe9d6f557758b51fae0acf85d1f71968a237fec299088536830fc862d25e02039de9ea13176b298a68aaa644eac958acbe1f4e143 OpenSceneGraph-3.4.1.tar.gz
016b09874bd6ca14cf1dba9274df4fc0413d2d97c3438135ecf6c5726029963f1ff279eb4986afe86173739512799e1e8ee5f7443e30fe1131524405a9d002be musl-fixes.patch
-8fa606d29ff7f45b9ada05482f61f99541d6b7803ba2fcb1d82c2b4c4045db7706334075a90a100cad5b9c1e25d290c4be6899fb12b36593e004b830cf1bdb64 replace-deprecated-FFmpeg-API-to-fix-build-with-ffmp.patch
a3e69609b2e3c51002f4babd1c5bd64fc9c32b14fc9232f4b4f345c6e96134bc80a0fe54ce3445059b4d0512d5ac1ec434101fe976b71f24c68b3569265e21d9 add-missing-include-for-ppc64le.patch"
diff --git a/testing/openscenegraph/replace-deprecated-FFmpeg-API-to-fix-build-with-ffmp.patch b/testing/openscenegraph/replace-deprecated-FFmpeg-API-to-fix-build-with-ffmp.patch
deleted file mode 100644
index 424391aa93..0000000000
--- a/testing/openscenegraph/replace-deprecated-FFmpeg-API-to-fix-build-with-ffmp.patch
+++ /dev/null
@@ -1,176 +0,0 @@
-From e85d5743341585c6e6eb1ac693884f80e1fa06ce Mon Sep 17 00:00:00 2001
-From: Andreas Cadhalpun <Andreas.Cadhalpun@googlemail.com>
-Date: Wed, 1 Jun 2016 10:32:35 +0100
-Subject: [PATCH] Replace deprecated FFmpeg API to fix build with ffmpeg-3.0.x
-
----
- src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp | 3 +-
- src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp | 48 +++++++++++++---------------
- src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp | 4 +--
- src/osgPlugins/ffmpeg/FFmpegParameters.cpp | 2 +-
- 4 files changed, 26 insertions(+), 31 deletions(-)
-
-diff --git a/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp b/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp
-index 665c68f5f..636bddd25 100644
---- a/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp
-+++ b/src/osgPlugins/ffmpeg/FFmpegDecoderAudio.cpp
-@@ -227,8 +227,7 @@ printf("### CONVERTING from sample format %s TO %s\n\t\tFROM %d TO %d channels\n
- if (avcodec_open2(m_context, p_codec, NULL) < 0)
- throw std::runtime_error("avcodec_open() failed");
-
-- m_context->get_buffer = avcodec_default_get_buffer;
-- m_context->release_buffer = avcodec_default_release_buffer;
-+ m_context->get_buffer2 = avcodec_default_get_buffer2;
-
- }
-
-diff --git a/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp b/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp
-index 9375657aa..083d3dbf5 100644
---- a/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp
-+++ b/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.cpp
-@@ -71,7 +71,7 @@ void FFmpegDecoderVideo::open(AVStream * const stream)
- findAspectRatio();
-
- // Find out whether we support Alpha channel
-- m_alpha_channel = (m_context->pix_fmt == PIX_FMT_YUVA420P);
-+ m_alpha_channel = (m_context->pix_fmt == AV_PIX_FMT_YUVA420P);
-
- // Find out the framerate
- #if LIBAVCODEC_VERSION_MAJOR >= 56
-@@ -95,20 +95,19 @@ void FFmpegDecoderVideo::open(AVStream * const stream)
- throw std::runtime_error("avcodec_open() failed");
-
- // Allocate video frame
-- m_frame.reset(avcodec_alloc_frame());
-+ m_frame.reset(av_frame_alloc());
-
- // Allocate converted RGB frame
-- m_frame_rgba.reset(avcodec_alloc_frame());
-- m_buffer_rgba[0].resize(avpicture_get_size(PIX_FMT_RGB24, width(), height()));
-+ m_frame_rgba.reset(av_frame_alloc());
-+ m_buffer_rgba[0].resize(avpicture_get_size(AV_PIX_FMT_RGB24, width(), height()));
- m_buffer_rgba[1].resize(m_buffer_rgba[0].size());
-
- // Assign appropriate parts of the buffer to image planes in m_frame_rgba
-- avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[0])[0], PIX_FMT_RGB24, width(), height());
-+ avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[0])[0], AV_PIX_FMT_RGB24, width(), height());
-
- // Override get_buffer()/release_buffer() from codec context in order to retrieve the PTS of each frame.
- m_context->opaque = this;
-- m_context->get_buffer = getBuffer;
-- m_context->release_buffer = releaseBuffer;
-+ m_context->get_buffer2 = getBuffer;
- }
-
-
-@@ -267,8 +266,8 @@ int FFmpegDecoderVideo::convert(AVPicture *dst, int dst_pix_fmt, AVPicture *src,
- #ifdef USE_SWSCALE
- if (m_swscale_ctx==0)
- {
-- m_swscale_ctx = sws_getContext(src_width, src_height, (PixelFormat) src_pix_fmt,
-- src_width, src_height, (PixelFormat) dst_pix_fmt,
-+ m_swscale_ctx = sws_getContext(src_width, src_height, (AVPixelFormat) src_pix_fmt,
-+ src_width, src_height, (AVPixelFormat) dst_pix_fmt,
- /*SWS_BILINEAR*/ SWS_BICUBIC, NULL, NULL, NULL);
- }
-
-@@ -315,14 +314,14 @@ void FFmpegDecoderVideo::publishFrame(const double delay, bool audio_disabled)
- AVPicture * const dst = (AVPicture *) m_frame_rgba.get();
-
- // Assign appropriate parts of the buffer to image planes in m_frame_rgba
-- avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[m_writeBuffer])[0], PIX_FMT_RGB24, width(), height());
-+ avpicture_fill((AVPicture *) (m_frame_rgba).get(), &(m_buffer_rgba[m_writeBuffer])[0], AV_PIX_FMT_RGB24, width(), height());
-
- // Convert YUVA420p (i.e. YUV420p plus alpha channel) using our own routine
-
-- if (m_context->pix_fmt == PIX_FMT_YUVA420P)
-+ if (m_context->pix_fmt == AV_PIX_FMT_YUVA420P)
- yuva420pToRgba(dst, src, width(), height());
- else
-- convert(dst, PIX_FMT_RGB24, src, m_context->pix_fmt, width(), height());
-+ convert(dst, AV_PIX_FMT_RGB24, src, m_context->pix_fmt, width(), height());
-
- // Wait 'delay' seconds before publishing the picture.
- int i_delay = static_cast<int>(delay * 1000000 + 0.5);
-@@ -349,7 +348,7 @@ void FFmpegDecoderVideo::publishFrame(const double delay, bool audio_disabled)
-
- void FFmpegDecoderVideo::yuva420pToRgba(AVPicture * const dst, AVPicture * const src, int width, int height)
- {
-- convert(dst, PIX_FMT_RGB24, src, m_context->pix_fmt, width, height);
-+ convert(dst, AV_PIX_FMT_RGB24, src, m_context->pix_fmt, width, height);
-
- const size_t bpp = 4;
-
-@@ -367,31 +366,28 @@ void FFmpegDecoderVideo::yuva420pToRgba(AVPicture * const dst, AVPicture * const
- }
- }
-
--
--
--int FFmpegDecoderVideo::getBuffer(AVCodecContext * const context, AVFrame * const picture)
-+int FFmpegDecoderVideo::getBuffer(AVCodecContext * const context, AVFrame * const picture, int flags)
- {
-+ AVBufferRef *ref;
- const FFmpegDecoderVideo * const this_ = reinterpret_cast<const FFmpegDecoderVideo*>(context->opaque);
-
-- const int result = avcodec_default_get_buffer(context, picture);
-+ const int result = avcodec_default_get_buffer2(context, picture, flags);
- int64_t * p_pts = reinterpret_cast<int64_t*>( av_malloc(sizeof(int64_t)) );
-
- *p_pts = this_->m_packet_pts;
- picture->opaque = p_pts;
-
-+ ref = av_buffer_create((uint8_t *)picture->opaque, sizeof(int64_t), FFmpegDecoderVideo::freeBuffer, picture->buf[0], flags);
-+ picture->buf[0] = ref;
-+
- return result;
- }
-
--
--
--void FFmpegDecoderVideo::releaseBuffer(AVCodecContext * const context, AVFrame * const picture)
-+void FFmpegDecoderVideo::freeBuffer(void *opaque, uint8_t *data)
- {
-- if (picture != 0)
-- av_freep(&picture->opaque);
--
-- avcodec_default_release_buffer(context, picture);
-+ AVBufferRef *ref = (AVBufferRef *)opaque;
-+ av_buffer_unref(&ref);
-+ av_free(data);
- }
-
--
--
- } // namespace osgFFmpeg
-diff --git a/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp b/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp
-index 7883b177c..778c1a9b8 100644
---- a/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp
-+++ b/src/osgPlugins/ffmpeg/FFmpegDecoderVideo.hpp
-@@ -94,8 +94,8 @@ private:
- int src_pix_fmt, int src_width, int src_height);
-
-
-- static int getBuffer(AVCodecContext * context, AVFrame * picture);
-- static void releaseBuffer(AVCodecContext * context, AVFrame * picture);
-+ static int getBuffer(AVCodecContext * context, AVFrame * picture, int flags);
-+ static void freeBuffer(void * opaque, uint8_t *data);
-
- PacketQueue & m_packets;
- FFmpegClocks & m_clocks;
-diff --git a/src/osgPlugins/ffmpeg/FFmpegParameters.cpp b/src/osgPlugins/ffmpeg/FFmpegParameters.cpp
-index 288e44052..5915ab850 100644
---- a/src/osgPlugins/ffmpeg/FFmpegParameters.cpp
-+++ b/src/osgPlugins/ffmpeg/FFmpegParameters.cpp
-@@ -19,7 +19,7 @@ extern "C"
- #include <libavutil/pixdesc.h>
- }
-
--inline PixelFormat osg_av_get_pix_fmt(const char *name) { return av_get_pix_fmt(name); }
-+inline AVPixelFormat osg_av_get_pix_fmt(const char *name) { return av_get_pix_fmt(name); }
-
-
- namespace osgFFmpeg {
---
-2.13.1
-