aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openttd-opengfx
diff options
context:
space:
mode:
authorAdrian Siekierka <kontakt@asie.pl>2017-01-05 01:00:19 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-01-07 17:38:00 +0100
commit4558f4ef1284ca03a86ea1b7c3ea493b9bb03dcb (patch)
treedb6a1dade657f85f982fede9c267ad793e77c63b /testing/openttd-opengfx
parent1e75d6e3db03b11e5ed787e7aee254c30f1c8352 (diff)
downloadaports-4558f4ef1284ca03a86ea1b7c3ea493b9bb03dcb.tar.bz2
aports-4558f4ef1284ca03a86ea1b7c3ea493b9bb03dcb.tar.xz
testing/openttd-opengfx: new aport
Free graphics set for OpenTTD
Diffstat (limited to 'testing/openttd-opengfx')
-rw-r--r--testing/openttd-opengfx/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/openttd-opengfx/APKBUILD b/testing/openttd-opengfx/APKBUILD
new file mode 100644
index 0000000000..886188a9aa
--- /dev/null
+++ b/testing/openttd-opengfx/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Adrian Siekierka <kontakt@asie.pl>
+# Maintainer: Adrian Siekierka <kontakt@asie.pl>
+pkgname=openttd-opengfx
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="Free graphics set for OpenTTD"
+url="http://openttd.org/"
+arch="noarch"
+license="GPL2"
+depends=""
+makedepends=""
+source="https://binaries.openttd.org/extra/opengfx/$pkgver/opengfx-$pkgver-all.zip"
+builddir="$srcdir/opengfx-$pkgver"
+
+prepare() {
+ cd "$srcdir"
+ tar xf opengfx-$pkgver.tar
+}
+
+package() {
+ cd "$builddir"
+
+ mkdir -p "$pkgdir/usr/share/games/openttd/data"
+ install -Dm644 *.grf *.obg "$pkgdir/usr/share/games/openttd/data"
+}
+
+md5sums="e64352d0578822c6e5388b631b3086f7 opengfx-0.5.2-all.zip"
+sha256sums="19be61f1cb04cbb3cb9602f0b8eb6e6f56ecbefbfdd6e0e03f9579e5a5c1cbc8 opengfx-0.5.2-all.zip"
+sha512sums="2e2d940e42d859bd23211f2606d78db50695e394c2e106b6337811721e900d073f947d9bed8b2521bf98512583653a6e9db5da6b1fa2aa47fdb2626f15c618b5 opengfx-0.5.2-all.zip"