aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openxcap
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-03-02 14:48:09 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-03-02 14:48:09 +0000
commit67b70103d6fc74186ce861cc554508065dfa0051 (patch)
tree2b55d353ce6981dc3c4b004d53d5f0c082dd7db2 /testing/openxcap
parentc1dcf0a2f96b6605c529ef8f4e334ab661ed976e (diff)
parentcc4a8c13fff3d8637aa0eb0dd2df000036601f42 (diff)
downloadaports-67b70103d6fc74186ce861cc554508065dfa0051.tar.bz2
aports-67b70103d6fc74186ce861cc554508065dfa0051.tar.xz
Merge git://git.alpinelinux.org/aports
Conflicts: testing/openxcap/APKBUILD
Diffstat (limited to 'testing/openxcap')
-rw-r--r--testing/openxcap/APKBUILD2
-rw-r--r--testing/openxcap/openxcap.initd32
2 files changed, 21 insertions, 13 deletions
diff --git a/testing/openxcap/APKBUILD b/testing/openxcap/APKBUILD
index 25811d4ae0..812c6d16de 100644
--- a/testing/openxcap/APKBUILD
+++ b/testing/openxcap/APKBUILD
@@ -31,4 +31,4 @@ build() {
md5sums="155b1ee85dd3217e5647ad3ac9f72cf6 openxcap-2.0.0.tar.gz
7a18872843586717eaf3879444cc13d2 config.ini
-5bebac590cb06b0eacaf040116bc354e openxcap.initd"
+0043d28e9e6e51e03661755d12080a28 openxcap.initd"
diff --git a/testing/openxcap/openxcap.initd b/testing/openxcap/openxcap.initd
index 69108afd8a..03286cce3d 100644
--- a/testing/openxcap/openxcap.initd
+++ b/testing/openxcap/openxcap.initd
@@ -1,23 +1,31 @@
#!/sbin/runscript
-#
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
-daemon=/usr/bin/openxcap
-pidfile=/var/run/openxcap/openxcap.pid
+INSTALL_DIR="/usr/bin"
+RUNTIME_DIR="/var/run/openxcap"
+DEFAULTS="/etc/default/openxcap"
+SERVER="$INSTALL_DIR/openxcap"
+PID="$RUNTIME_DIR/openxcap.pid"
+OPTIONS=""
+NAME="openxcap"
+DESC="OpenXCAP server"
depend() {
- need net
- after firewall
+ need net
+ after firewall
}
start() {
- ebegin "Starting OpenXCAP Presence Server"
- start-stop-daemon --start --quiet --pidfile $pidfile --exec $daemon
- eend $?
+ ebegin "Starting $DESC: $NAME "
+ start-stop-daemon --start --quiet --pidfile $PID --exec $SERVER -- $OPTIONS
+ eend $?
}
-stop() {
- ebegin "Stopping OpenXCAP Presence Server"
- start-stop-daemon --stop --quiet --signal 15 --pidfile $pidfile
- eend $?
+stop () {
+ ebegin -n "Stopping $DESC: $NAME "
+ start-stop-daemon --stop --quiet --oknodo --signal 15 --pidfile $PID
+ eend $?
}
+exit 0
+