aboutsummaryrefslogtreecommitdiffstats
path: root/testing/openxcap
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-02-27 15:42:52 +0000
committerFrancesco Colista <francesco.colista@gmail.com>2011-03-02 09:19:53 +0000
commita3b37bc56a794d671a61ef4bfd177840d94ec2f8 (patch)
treea2804cad7fc352e38e13a8ad4a84163bc436922c /testing/openxcap
parentf2962737b3575ab017763f49ee9df481a067b6e0 (diff)
downloadaports-a3b37bc56a794d671a61ef4bfd177840d94ec2f8.tar.bz2
aports-a3b37bc56a794d671a61ef4bfd177840d94ec2f8.tar.xz
testing/openxcap: upgrade to 2.0, fixed APKBUILD
Diffstat (limited to 'testing/openxcap')
-rw-r--r--testing/openxcap/APKBUILD13
-rw-r--r--testing/openxcap/openxcap.initd32
2 files changed, 25 insertions, 20 deletions
diff --git a/testing/openxcap/APKBUILD b/testing/openxcap/APKBUILD
index c216536810..513d5bd54b 100644
--- a/testing/openxcap/APKBUILD
+++ b/testing/openxcap/APKBUILD
@@ -1,9 +1,8 @@
# Contributor: Francesco Colista <francesco.colista@gmail.com>
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
-
pkgname=openxcap
-pkgver=1.2.0
-pkgrel=4
+pkgver=2.0.0
+pkgrel=0
pkgdesc="Open source fully featured XCAP server "
url="http://openxcap.org"
pkgusers="openxcap"
@@ -16,9 +15,7 @@ makedepends="python-dev"
install="$pkgname.pre-install $pkgname.post-install"
source="http://download.ag-projects.com/XCAP/$pkgname-$pkgver.tar.gz
config.ini
- openxcap.initd
-"
-
+ openxcap.initd"
build() {
cd "$srcdir"/$pkgname-$pkgver
@@ -35,6 +32,6 @@ build() {
install -d -o openxcap "$pkgdir"/var/run/openxcap
}
-md5sums="ec34570deee2019a1ebf9a012a476c26 openxcap-1.2.0.tar.gz
+md5sums="155b1ee85dd3217e5647ad3ac9f72cf6 openxcap-2.0.0.tar.gz
7a18872843586717eaf3879444cc13d2 config.ini
-5bebac590cb06b0eacaf040116bc354e openxcap.initd"
+0043d28e9e6e51e03661755d12080a28 openxcap.initd"
diff --git a/testing/openxcap/openxcap.initd b/testing/openxcap/openxcap.initd
index 69108afd8a..03286cce3d 100644
--- a/testing/openxcap/openxcap.initd
+++ b/testing/openxcap/openxcap.initd
@@ -1,23 +1,31 @@
#!/sbin/runscript
-#
+PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
-daemon=/usr/bin/openxcap
-pidfile=/var/run/openxcap/openxcap.pid
+INSTALL_DIR="/usr/bin"
+RUNTIME_DIR="/var/run/openxcap"
+DEFAULTS="/etc/default/openxcap"
+SERVER="$INSTALL_DIR/openxcap"
+PID="$RUNTIME_DIR/openxcap.pid"
+OPTIONS=""
+NAME="openxcap"
+DESC="OpenXCAP server"
depend() {
- need net
- after firewall
+ need net
+ after firewall
}
start() {
- ebegin "Starting OpenXCAP Presence Server"
- start-stop-daemon --start --quiet --pidfile $pidfile --exec $daemon
- eend $?
+ ebegin "Starting $DESC: $NAME "
+ start-stop-daemon --start --quiet --pidfile $PID --exec $SERVER -- $OPTIONS
+ eend $?
}
-stop() {
- ebegin "Stopping OpenXCAP Presence Server"
- start-stop-daemon --stop --quiet --signal 15 --pidfile $pidfile
- eend $?
+stop () {
+ ebegin -n "Stopping $DESC: $NAME "
+ start-stop-daemon --stop --quiet --oknodo --signal 15 --pidfile $PID
+ eend $?
}
+exit 0
+