aboutsummaryrefslogtreecommitdiffstats
path: root/testing/opmsg
diff options
context:
space:
mode:
authorstf <7o5rfu92t@ctrlc.hu>2016-11-13 21:47:08 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-28 08:31:45 +0000
commit692bb4941e1fa0d765f51fcebc080a701700f5a2 (patch)
tree2eec042a7c8d47719e4e56fc2c4fe9e5556417e2 /testing/opmsg
parent97f832b1bbd37633bc95dc19f05704221c7de919 (diff)
downloadaports-692bb4941e1fa0d765f51fcebc080a701700f5a2.tar.bz2
aports-692bb4941e1fa0d765f51fcebc080a701700f5a2.tar.xz
testing/opmsg initial commit
Diffstat (limited to 'testing/opmsg')
-rw-r--r--testing/opmsg/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/opmsg/APKBUILD b/testing/opmsg/APKBUILD
new file mode 100644
index 0000000000..7fcf4eaa22
--- /dev/null
+++ b/testing/opmsg/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: stef <l0ls0fo2i@ctrlc.hu>
+# Maintainer:
+pkgname=opmsg
+pkgver=1.76
+pkgrel=0
+pkgdesc="opmsg gpg-like encryption system"
+url="https://github.com/stealth/opmsg"
+arch="all"
+license="GPL3+"
+depends=""
+makedepends="libressl-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/stealth/opmsg/archive/rel-${pkgver}s.tar.gz"
+builddir="$srcdir/$pkgname-rel-${pkgver}s"
+
+build() {
+ cd "$builddir/src"
+ make DEFS="-DHAVE_BN_GENCB_NEW=0 -DHAVE_LIBRESSL" opmsg opmux
+}
+
+package() {
+ cd "$builddir/src"
+ mkdir -p "$pkgdir"/usr/bin
+ cp opmsg opmux "$pkgdir"/usr/bin
+}
+
+sha512sums="b2605d73295722a9d66b9add60f7d4c765bef5abc45bcddf77239b590fda54b84ff79c8e7cf64749b90d349809311a3bcb453a2deec2bb785a2c2fde2c58d85b opmsg-1.76.tar.gz"