aboutsummaryrefslogtreecommitdiffstats
path: root/testing/oq
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2019-12-04 23:01:40 +0100
committerMilan P. Stanić <mps@arvanta.net>2019-12-04 23:01:40 +0100
commit84d43c4e3e26d2e3fe9075a8d872417183e1eee6 (patch)
tree1470e37021061625ede3558938c9e2ff95831f92 /testing/oq
parentcaa8abfb971399fbffa0b0c8b6cbfb20faf80cfd (diff)
downloadaports-84d43c4e3e26d2e3fe9075a8d872417183e1eee6.tar.bz2
aports-84d43c4e3e26d2e3fe9075a8d872417183e1eee6.tar.xz
testing/oq: fix build, reenable
Diffstat (limited to 'testing/oq')
-rw-r--r--testing/oq/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/testing/oq/APKBUILD b/testing/oq/APKBUILD
index bd2c5b562e..67750afa8f 100644
--- a/testing/oq/APKBUILD
+++ b/testing/oq/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="A portable jq wrapper with support of other formats than JSON"
url="https://github.com/blacksmoke16/oq"
# arch="x86_64 aarch64" # limited by Crystal
# `gcc "${@}" -o '/home/buildozer/aports/testing/oq/src/oq-0.2.1/bin/oq' -rdynamic -lyaml -lxml2 -lpcre -lm /usr/lib/libgc.a -lpthread /usr/lib/crystal/core/ext/libcrystal.a -levent -lrt -L/usr/lib -L/usr/local/lib`
-arch=""
+arch="x86_64 aarch64" # limited by Crystal
license="MIT"
depends="jq"
makedepends="crystal libxml2-dev yaml-dev"
@@ -15,6 +15,7 @@ source="https://github.com/Blacksmoke16/oq/archive/v$pkgver/$pkgname-$pkgver.tar
builddir="$srcdir/$pkgname-$pkgver"
build() {
+ mkdir bin
crystal build --release -o bin/oq src/oq_cli.cr
}