aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ostinato
diff options
context:
space:
mode:
authorCorentin Henry <corentinhenry@gmail.com>2016-04-21 11:32:18 +0000
committerJakub Jirutka <jakub@jirutka.cz>2016-06-03 15:14:27 +0200
commit39c0e9da71ede237ed53fa79269435a9a5f7b067 (patch)
tree45d049d05481ed952f6bbfa85995870daf85502d /testing/ostinato
parent6edae4e6b231d8999a7130172a5b839f1be10479 (diff)
downloadaports-39c0e9da71ede237ed53fa79269435a9a5f7b067.tar.bz2
aports-39c0e9da71ede237ed53fa79269435a9a5f7b067.tar.xz
testing/ostinato: new aport
http://ostinato.org/ Packet/Traffic Generator and Analyzer
Diffstat (limited to 'testing/ostinato')
-rw-r--r--testing/ostinato/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/ostinato/APKBUILD b/testing/ostinato/APKBUILD
new file mode 100644
index 0000000000..4927b7ab72
--- /dev/null
+++ b/testing/ostinato/APKBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Corentin Henry <corentinhenry@gmail.com>
+# Contributor: Corentin Henry <corentinhenry@gmail.com>
+pkgname=ostinato
+pkgver=0.7.1
+pkgrel=0
+pkgdesc="Packet/Traffic Generator and Analyzer"
+url="https://www.ostinato.org/"
+arch="all"
+license="GPLv3"
+depends=""
+makedepends="qt-dev protobuf-dev libpcap-dev paxmark"
+subpackages="$pkgname-drone $pkgname-gui"
+source="http://dl.bintray.com/pstavirs/ostinato/$pkgname-src-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+
+ qmake PREFIX=/usr || return 1
+ make
+}
+
+package() {
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir" install || return 1
+ paxmark -m "$pkgdir"/usr/bin/drone || return 1
+ paxmark -m "$pkgdir"/usr/bin/ostinato
+}
+
+drone() {
+ pkgdesc="ostinato controller"
+
+ install -d "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/drone "$subpkgdir"/usr/bin/drone
+}
+
+gui() {
+ pkgdesc="graphical controller for ostinato"
+
+ install -d "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/ostinato "$subpkgdir"/usr/bin/ostinato
+}
+
+md5sums="84c1ad90d3132d42b40025c6167fd8f0 ostinato-src-0.7.1.tar.gz"
+sha256sums="7b46eb5257b5b50ee5317dcf9158c6e78ba36a04858c3c9228fa02e8a98364c2 ostinato-src-0.7.1.tar.gz"
+sha512sums="4494584930445567bd191e265a6f877fdbbe7aa38c23184d7aa7baf7a75de33c351fc7edac4efe1ce112be02a295d6851fa7df2505eb306f90d564c8e1d296ed ostinato-src-0.7.1.tar.gz"