aboutsummaryrefslogtreecommitdiffstats
path: root/testing/paper-icon-theme/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-10-19 23:06:05 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-10-19 23:06:05 +0200
commit7cce2fc069d1d30c3826bf6c4db478ef1190ce9a (patch)
tree302149e74c1811b80a3ba8f8b4a8a192cd54a036 /testing/paper-icon-theme/APKBUILD
parente66f3ed7ffec598006fa08bb84144b24e045c7f6 (diff)
downloadaports-7cce2fc069d1d30c3826bf6c4db478ef1190ce9a.tar.bz2
aports-7cce2fc069d1d30c3826bf6c4db478ef1190ce9a.tar.xz
testing/paper-icon-theme: new aport
Diffstat (limited to 'testing/paper-icon-theme/APKBUILD')
-rw-r--r--testing/paper-icon-theme/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/paper-icon-theme/APKBUILD b/testing/paper-icon-theme/APKBUILD
new file mode 100644
index 0000000000..7971461129
--- /dev/null
+++ b/testing/paper-icon-theme/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
+pkgname=paper-icon-theme
+pkgver=1.3.4
+pkgrel=0
+pkgdesc="Paper is a modern freedesktop icon theme"
+url="http://snwh.org/paper"
+arch="noarch"
+license="CC-BY-SA-4.0"
+depends=""
+makedepends="automake autoconf libtool"
+install=""
+options="!strip"
+subpackages=""
+source="paper-icon-theme-$pkgver.tar.gz::https://github.com/snwh/paper-icon-theme/archive/v$pkgver.tar.gz"
+builddir="$srcdir/paper-icon-theme-$pkgver"
+
+build() {
+ cd "$builddir"
+ autoreconf -vif
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="31ade3eec6ca5e0d705c84805b4db7fb paper-icon-theme-1.3.4.tar.gz"
+sha256sums="b32fc5f084b6be7dfe8275b5f1edfdcafe6200da7df90c13cc1d2628dd50c843 paper-icon-theme-1.3.4.tar.gz"
+sha512sums="3fbab008d2bbdab0af30cf4a9c67252aa9e9416a76a45be25e59d0e6658d5a93038f50699fe195e31eb22769084a904d22fe9ff32a91c890ad9c7bfd58cf7b56 paper-icon-theme-1.3.4.tar.gz"