aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pelican
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2016-11-11 06:21:44 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 10:50:45 +0200
commit1f74663d8c9593032d03d537fc62dfd7cc833c3e (patch)
tree892e432ee4985bc89eeee3a05e0e9607c5eb3ba3 /testing/pelican
parent05cf83925d92f0ba608eec95a7cbf3187c6c12e7 (diff)
downloadaports-1f74663d8c9593032d03d537fc62dfd7cc833c3e.tar.bz2
aports-1f74663d8c9593032d03d537fc62dfd7cc833c3e.tar.xz
testing/pelican: fix requirements and enable py3
Diffstat (limited to 'testing/pelican')
-rw-r--r--testing/pelican/APKBUILD64
1 files changed, 36 insertions, 28 deletions
diff --git a/testing/pelican/APKBUILD b/testing/pelican/APKBUILD
index 0599c5cd30..541b89caa0 100644
--- a/testing/pelican/APKBUILD
+++ b/testing/pelican/APKBUILD
@@ -7,59 +7,67 @@ pkgrel=1
pkgdesc="A tool to generate a static blog from reStructuredText or Markdown input files."
url="https://pypi.python.org/pypi/pelican/"
arch="noarch"
-license="GPL3"
-depends="python2 bash fabric py-feedparser py-pygments py-docutils py-sphinx py-blinker py-unidecode py-mock py-markdown py-beautifulsoup4 py-lxml py-six py-tz py-jinja2 py-django py-dateutil py-nose"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+license="AGPL3"
+depends="bash py-feedgenerator py-pygments py-docutils py-blinker py-unidecode
+ py-markdown py-jinja2 py-dateutil"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
- use-django-feedgenerator.patch
pelican
pelican-import
pelican-quickstart
pelican-themes
"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
+ cd "$builddir"
python2 setup.py build || return 1
+ python3 setup.py build || return 1
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
- install -Dm755 "$srcdir"/pelican "$pkgdir"/usr/bin/pelican || return 1
- install -Dm755 "$srcdir"/pelican-import "$pkgdir"/usr/bin/pelican-import || return 1
- install -Dm755 "$srcdir"/pelican-quickstart "$pkgdir"/usr/bin/pelican-quickstart || return 1
- install -Dm755 "$srcdir"/pelican-themes "$pkgdir"/usr/bin/pelican-themes || return 1
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
}
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+
+ install -Dm755 "$srcdir"/pelican "$pkgdir"/usr/bin/pelican || return 1
+ install -Dm755 "$srcdir"/pelican-import "$pkgdir"/usr/bin/pelican-import || return 1
+ install -Dm755 "$srcdir"/pelican-quickstart "$pkgdir"/usr/bin/pelican-quickstart || return 1
+ install -Dm755 "$srcdir"/pelican-themes "$pkgdir"/usr/bin/pelican-themes || return 1
+}
+
+
md5sums="ee4110fc60af26459f4e2f7c9fa9cdd5 pelican-3.6.3.tar.gz
-bc2fd60e16a1bc2c9665a444361a193c use-django-feedgenerator.patch
4bf7b73a88c503e86f9d65f868460c3e pelican
e8bb1251692b788084cf512fdde9fe01 pelican-import
15041b4677c2a2500d620a07a0a6020a pelican-quickstart
00c3394ad364cbf80e15ea0b7f060071 pelican-themes"
sha256sums="13b9c41ea3342b7eb0fd7f74078b5a8d5035632f05d8680266f50f4c5626c9c2 pelican-3.6.3.tar.gz
-f77f7013d47c60560cbf8d18d7796119a2e7aa2d55a1d777e6ab6258cfae182f use-django-feedgenerator.patch
11b7248aed883d72f385563f2d849c5f42f623716a5cfb3bbdf9c61a4c59ab7f pelican
d0d6f9b96f10fa0c987ec45b41e7e4b64358f83e78f5c30fa056c860a6242b75 pelican-import
f563d146419d0ba4a3cc052bbb2bbf8cbbaa5f6a6ae7106c4c6a9e1f627590f4 pelican-quickstart
5370507e6ec10f4ad1cf8f06ee148debfd51ecb588670d70e649cb9019cb53d0 pelican-themes"
sha512sums="2494c263ba8dcbe790dda7c0e67e473d7d00326c2f35319b45b424f7fbea21139c70d1174b8363535bf37a1670f0f08c43abca0b5029efc42a57ed2d7de6e6b2 pelican-3.6.3.tar.gz
-1536d1f7acf76cf8d2770e731f92512102455d990df325b54f7099bfb905754b2d84e5a16a2ebb33ead56b76aa44efe080456aa1e01fa783171d3f6e70b895a6 use-django-feedgenerator.patch
430260ecf616254ebd402caa0fc39a220748e95460f670bf43ab50922cdff3ba142aacc12f862ce8b12b069b8218fe24b8387723911e3b3acc83960d05cfafff pelican
f7638795328ca5e103d8e0fa41b3b559f0657d75465fd88ca64be3514ecbc6ef0566ffc687a8869291d6b80b57fa7695ab454c33f014934eebda7ae00ec92763 pelican-import
7fb3002ee7cee43bc8f216d6df67c8144059090598a25a676880eeccc36d8d0d7063eac3792115843c3d9a5c3d859ad63bae5c9eeb858878f921fe95e0d43c95 pelican-quickstart