aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-anyevent-influxdb/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 23:01:18 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 23:01:18 -0300
commitf7bf64d3b4681d13e52ec6937ae094db3de93b10 (patch)
tree108c195110be59dc7b6d103c5b310ef3665bd1fe /testing/perl-anyevent-influxdb/APKBUILD
parentebd57b7dec6b19adb77c4dfe26d72e5e537a65aa (diff)
downloadaports-f7bf64d3b4681d13e52ec6937ae094db3de93b10.tar.bz2
aports-f7bf64d3b4681d13e52ec6937ae094db3de93b10.tar.xz
testing/perl-anyevent-influxdb: fix url fix license
Diffstat (limited to 'testing/perl-anyevent-influxdb/APKBUILD')
-rw-r--r--testing/perl-anyevent-influxdb/APKBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/testing/perl-anyevent-influxdb/APKBUILD b/testing/perl-anyevent-influxdb/APKBUILD
index 99d9f6b723..aae5a0446a 100644
--- a/testing/perl-anyevent-influxdb/APKBUILD
+++ b/testing/perl-anyevent-influxdb/APKBUILD
@@ -4,38 +4,34 @@
pkgname=perl-anyevent-influxdb
_pkgreal=AnyEvent-InfluxDB
pkgver=1.0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="An asynchronous library for InfluxDB time-series database"
-url="http://search.cpan.org/dist/AnyEvent-InfluxDB/"
+url="https://metacpan.org/release/AnyEvent-InfluxDB"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends="perl-anyevent-http perl-anyevent perl-list-moreutils perl-moo perl-json perl-uri perl-uri-encode-xs"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+cpandepends="perl-anyevent-http perl-anyevent perl-list-moreutils perl-moo
+ perl-json perl-uri perl-uri-encode-xs"
cpanmakedepends="perl-module-build"
-cpancheckdepends=""
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/A/AJ/AJGB/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
- perl Build.PL installdirs=vendor || return 1
+ perl Build.PL installdirs=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
./Build && ./Build test
}
package() {
- cd "$builddir"
- ./Build install destdir="$pkgdir" || return 1
+ ./Build install destdir="$pkgdir"
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}