aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-cgi-expand
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 23:08:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 23:08:02 -0300
commit678864babce3bc0995b5360c6712911b9fc4fc5f (patch)
tree349f4cc4326badbdbbd23f7a240c4bde3feea90b /testing/perl-cgi-expand
parent670711c6bdbf935fb7990e136e1253066fe4dc97 (diff)
downloadaports-678864babce3bc0995b5360c6712911b9fc4fc5f.tar.bz2
aports-678864babce3bc0995b5360c6712911b9fc4fc5f.tar.xz
testing/perl-cgi-expand: fix url fix license
Diffstat (limited to 'testing/perl-cgi-expand')
-rw-r--r--testing/perl-cgi-expand/APKBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/testing/perl-cgi-expand/APKBUILD b/testing/perl-cgi-expand/APKBUILD
index fa0500ff2e..ad9b789666 100644
--- a/testing/perl-cgi-expand/APKBUILD
+++ b/testing/perl-cgi-expand/APKBUILD
@@ -4,43 +4,36 @@
pkgname=perl-cgi-expand
_pkgreal=CGI-Expand
pkgver=2.05
-pkgrel=0
+pkgrel=1
pkgdesc="convert flat hash to nested data using TT2's dot convention"
-url="http://search.cpan.org/dist/CGI-Expand/"
+url="https://metacpan.org/release/CGI-Expand"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-test-exception"
-cpanmakedepends=""
-cpancheckdepends=""
depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/B/BO/BOWMANBS/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}