aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-cwmp
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-09-21 06:38:19 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-09-21 06:48:50 +0000
commit5874dfc1a97f0e94abc1be8604aa67302aef982c (patch)
tree91d5f8dc26ad47ddcc72c6625aed4f65ec73c156 /testing/perl-cwmp
parent4849da47c9158d44a7bf0ea0768035b2ba06aa53 (diff)
downloadaports-5874dfc1a97f0e94abc1be8604aa67302aef982c.tar.bz2
aports-5874dfc1a97f0e94abc1be8604aa67302aef982c.tar.xz
testing/perl-cwmp: new aport
Perl ACS server implementing CWMP protocol to manage CPE clients
Diffstat (limited to 'testing/perl-cwmp')
-rw-r--r--testing/perl-cwmp/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/perl-cwmp/APKBUILD b/testing/perl-cwmp/APKBUILD
new file mode 100644
index 0000000000..2b9f327fb9
--- /dev/null
+++ b/testing/perl-cwmp/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=perl-cwmp
+pkgver=0_git20150919
+pkgrel=0
+pkgdesc="Perl ACS server implementing CWMP protocol to manage CPE clients"
+url="https://github.com/dpavlin/perl-cwmp"
+arch="noarch"
+license="GPL2"
+depends="perl-class-accessor perl-data-dump perl-file-remove
+ perl-file-slurp perl-hash-merge perl-module-install perl-ipc-dirqueue
+ perl-module-pluggable perl-pathtools perl-xml-bare perl-xml-generator
+ perl-yaml-syck perl-yaml-tiny perl-json-xs perl-yaml perl-common-sense
+ perl-types-serialiser perl-net-http perl-dbm-deep perl-term-shelly"
+depends_dev=
+makedepends="perl $depends_dev"
+install=
+subpackages="$pkgname-doc"
+source="http://dev.alpinelinux.org:/archive/$pkgname/$pkgname-$pkgver.tar.gz
+ "
+giturl="https://github.com/dpavlin/perl-cwmp"
+disturl="http://dev.alpinelinux.org:/archive/$pkgname"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+
+prepare() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ for file in acs cli cpe-queue dump dump2test; do
+ install -D -m0755 bin/${file}.pl "$pkgdir"/usr/bin/${file}.pl
+ done
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="5533317abb05a198e3ffab05fa848279 perl-cwmp-0_git20150919.tar.gz"
+sha256sums="b2855523017734caa80f6d1e0ed21df23571a597dcd4269ea77195feabdf4534 perl-cwmp-0_git20150919.tar.gz"
+sha512sums="92211a11c7b23a939211aca51e5f26856fd4451c0b9f0743f622c1df2fa934020dd1bb9427947c668462a9beae106c08366167080556a52179e6b92a76e35588 perl-cwmp-0_git20150919.tar.gz"