aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-datetime-format-sqlite
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-06 15:45:13 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-07-11 14:31:24 +0300
commitbc4cb10db356d855df45a989e988f106722a49f8 (patch)
treebf92709e040ba0a92d8a0f20a522d4eb4338de2f /testing/perl-datetime-format-sqlite
parent6ab7e53f60617bc32b84b73e21bcd2dbb37441f7 (diff)
downloadaports-bc4cb10db356d855df45a989e988f106722a49f8.tar.bz2
aports-bc4cb10db356d855df45a989e988f106722a49f8.tar.xz
testing/perl-datetime-format-sqlite: new aport
Parse and format SQLite dates and times http://search.cpan.org/dist/DateTime-Format-SQLite/
Diffstat (limited to 'testing/perl-datetime-format-sqlite')
-rw-r--r--testing/perl-datetime-format-sqlite/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/perl-datetime-format-sqlite/APKBUILD b/testing/perl-datetime-format-sqlite/APKBUILD
new file mode 100644
index 0000000000..90d65d87f0
--- /dev/null
+++ b/testing/perl-datetime-format-sqlite/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-datetime-format-sqlite
+_pkgreal=DateTime-Format-SQLite
+pkgver=0.11
+pkgrel=0
+pkgdesc="Parse and format SQLite dates and times"
+url="http://search.cpan.org/dist/DateTime-Format-SQLite/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-datetime-format-builder perl-datetime"
+cpanmakedepends=""
+cpancheckdepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/C/CF/CFAERBER/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="061f831c2a8d653706d315c1cff24ad887e3f8c65afdbd2140066735649c097be921f217e6e2761f8f34604066c618f296d40e9c650c3a1bb085cadbdfa7b7b9 DateTime-Format-SQLite-0.11.tar.gz"