aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-email-mime-attachment-stripper
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-28 01:18:42 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-28 01:18:42 -0300
commit002af6c7c787d954be5f571548500a9188ff103d (patch)
tree388ace58931236b88343f4f8d783e886e57e3f72 /testing/perl-email-mime-attachment-stripper
parent9ddeb49d0a1ef07118a7009a1c46415fb52743e0 (diff)
downloadaports-002af6c7c787d954be5f571548500a9188ff103d.tar.bz2
aports-002af6c7c787d954be5f571548500a9188ff103d.tar.xz
testing/perl-email-mime-attachment-stripper: fix url fix license
Diffstat (limited to 'testing/perl-email-mime-attachment-stripper')
-rw-r--r--testing/perl-email-mime-attachment-stripper/APKBUILD20
1 files changed, 8 insertions, 12 deletions
diff --git a/testing/perl-email-mime-attachment-stripper/APKBUILD b/testing/perl-email-mime-attachment-stripper/APKBUILD
index d0ba751659..b011aa5b26 100644
--- a/testing/perl-email-mime-attachment-stripper/APKBUILD
+++ b/testing/perl-email-mime-attachment-stripper/APKBUILD
@@ -4,35 +4,31 @@
pkgname=perl-email-mime-attachment-stripper
_pkgreal=Email-MIME-Attachment-Stripper
pkgver=1.317
-pkgrel=0
+pkgrel=1
pkgdesc="strip the attachments from an email"
-url="http://search.cpan.org/dist/Email-MIME-Attachment-Stripper/"
+url="https://metacpan.org/release/Email-MIME-Attachment-Stripper"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-email-mime-contenttype perl-email-mime"
-cpanmakedepends=" "
depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
-_builddir="$srcdir/$_pkgreal-$pkgver"
+builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$_builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make && make test
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}