aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-module-install-authorrequires/APKBUILD
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-10-29 03:01:16 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-11-02 18:32:40 -0300
commit1de6da22a567a799ed8bfdec070fe6afaf67a2b6 (patch)
tree9035f1e6baa4b6f13149efd86d06dfd514f52346 /testing/perl-module-install-authorrequires/APKBUILD
parent9629656da27bc89d6e7e1826a8aec071bca0664f (diff)
downloadaports-1de6da22a567a799ed8bfdec070fe6afaf67a2b6.tar.bz2
aports-1de6da22a567a799ed8bfdec070fe6afaf67a2b6.tar.xz
testing/perl-module-install-authorrequires: new aport
declare author-only dependencies https://metacpan.org/release/Module-Install-AuthorRequires/
Diffstat (limited to 'testing/perl-module-install-authorrequires/APKBUILD')
-rw-r--r--testing/perl-module-install-authorrequires/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/perl-module-install-authorrequires/APKBUILD b/testing/perl-module-install-authorrequires/APKBUILD
new file mode 100644
index 0000000000..830a3c034c
--- /dev/null
+++ b/testing/perl-module-install-authorrequires/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-module-install-authorrequires
+_pkgreal=Module-Install-AuthorRequires
+pkgver=0.02
+pkgrel=0
+pkgdesc="declare author-only dependencies"
+url="https://metacpan.org/release/Module-Install-AuthorRequires/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+cpandepends="perl-module-install"
+depends="$cpandepends"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/F/FL/FLORA/Module-Install-AuthorRequires-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="66d2a603e5700eca0a93523b6adcd0330d439b41730b7ccb2606fc4e43e4b6620cf376637fcbbe71d4733ce144c46822fecac39d4bed3d5303b68863425d9819 Module-Install-AuthorRequires-0.02.tar.gz"