aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-module-install-authortests/APKBUILD
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-10-29 03:11:45 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-11-02 18:33:12 -0300
commitae2a3af84f47dc250e1e4862c2a16330228027cc (patch)
tree3ccd3d64c4eb2a1454efc60840dc6b2a8b51a830 /testing/perl-module-install-authortests/APKBUILD
parent1de6da22a567a799ed8bfdec070fe6afaf67a2b6 (diff)
downloadaports-ae2a3af84f47dc250e1e4862c2a16330228027cc.tar.bz2
aports-ae2a3af84f47dc250e1e4862c2a16330228027cc.tar.xz
testing/perl-module-install-authortests: new aport
designate tests only run by module authors https://metacpan.org/release/Module-Install-AuthorTests/
Diffstat (limited to 'testing/perl-module-install-authortests/APKBUILD')
-rw-r--r--testing/perl-module-install-authortests/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/perl-module-install-authortests/APKBUILD b/testing/perl-module-install-authortests/APKBUILD
new file mode 100644
index 0000000000..45f5f69239
--- /dev/null
+++ b/testing/perl-module-install-authortests/APKBUILD
@@ -0,0 +1,35 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-module-install-authortests
+_pkgreal=Module-Install-AuthorTests
+pkgver=0.002
+pkgrel=0
+pkgdesc="designate tests only run by module authors"
+url="https://metacpan.org/release/Module-Install-AuthorTests/"
+arch="noarch"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+cpandepends="perl-module-install"
+depends="$cpandepends"
+makedepends="perl-dev"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/R/RJ/RJBS/Module-Install-AuthorTests-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="13f3c9018171500ec0090f5f634508b3b0b9554fe9b02cf47f008d1e0005358e1b7d65b4b1347c86aff93da6ae60f0e5c1bdcb1f8c01de727231d3481b5b7153 Module-Install-AuthorTests-0.002.tar.gz"