aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-specio
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-04-08 23:24:20 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-04-08 23:24:20 +0000
commit9fd752de5597548d6c5c10211a7c786288d83132 (patch)
tree44839a2d7dcffcefaff68c3815a0fef2b2a91e86 /testing/perl-specio
parentc27919ad73663f56133d337846f3bde9483c5e26 (diff)
downloadaports-9fd752de5597548d6c5c10211a7c786288d83132.tar.bz2
aports-9fd752de5597548d6c5c10211a7c786288d83132.tar.xz
testing/perl-specio: New aport
Adding new package to the archive because there is one package (community/perl-net-cli-interact) that FTBFS because it depends on this package.
Diffstat (limited to 'testing/perl-specio')
-rw-r--r--testing/perl-specio/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/perl-specio/APKBUILD b/testing/perl-specio/APKBUILD
new file mode 100644
index 0000000000..2759159e59
--- /dev/null
+++ b/testing/perl-specio/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Breno Leitao <breno.leitao@gmail.com>
+# Maintainer: Breno Leitao <breno.leitao@gmail.com>
+pkgname=perl-specio
+_pkgname=Specio
+pkgver=0.36
+pkgrel=0
+pkgdesc="Type constraints and coercions for Perl"
+url="https://github.com/houseabsolute/Specio"
+arch="all"
+license="Artistic"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/houseabsolute/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="739007e046d7f2d6a40e561ea9aeffea298fd111b3aa66f1f964fd80843319e0cbd83f39f9457ce3e8d59973313a35ead8065a94588fed84d687cc8ea5634501 perl-specio-0.36.tar.gz"