aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-test-command
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-01-11 15:18:49 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-01-11 17:30:06 +0000
commit66640594d8e7c5dbe728a03b80263aa7ab3409cf (patch)
tree2944365bd7a1e0c1195f09a841433df6a196667a /testing/perl-test-command
parent13aaa1c9ab8606ddd48e38cba0d8375228f83fee (diff)
downloadaports-66640594d8e7c5dbe728a03b80263aa7ab3409cf.tar.bz2
aports-66640594d8e7c5dbe728a03b80263aa7ab3409cf.tar.xz
testing/perl-test-command: new aport
Diffstat (limited to 'testing/perl-test-command')
-rw-r--r--testing/perl-test-command/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/perl-test-command/APKBUILD b/testing/perl-test-command/APKBUILD
new file mode 100644
index 0000000000..4252d961b4
--- /dev/null
+++ b/testing/perl-test-command/APKBUILD
@@ -0,0 +1,44 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=perl-test-command
+_pkgreal=Test-Command
+pkgver=0.11
+pkgrel=0
+pkgdesc="Perl module for Test-Command"
+url="http://search.cpan.org/dist/Test-Command/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends="perl-module-build"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/D/DA/DANBOO/$_pkgreal-$pkgver.tar.gz"
+
+_builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ if [ -e Build.PL ]; then
+ perl Build.PL installdirs=vendor || return 1
+ else
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ fi
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ ./Build && ./Build test
+}
+
+package() {
+ cd "$_builddir"
+ ./Build install destdir="$pkgdir" || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="9ab83c4695961dbe92cd86efe08f0634 Test-Command-0.11.tar.gz"
+sha256sums="28a3fc6fea73a19f563f11bd0f28186756d4c74207be6deacaad26d2081b9533 Test-Command-0.11.tar.gz"
+sha512sums="79a8f41132b965ad4f6e8b4d97f8fb6181a1e394bcf8825abda2c8ee12dd5f6ef8d7c69df84d306c3841bb516213742c4a0a43c2f3d6b39ce6e163d6d77f45f8 Test-Command-0.11.tar.gz"