aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-time-duration
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-03 06:59:21 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-03 06:59:21 -0300
commita04f7eab13be1862e265e021316295f5ad335ff1 (patch)
tree5e594b0d2a9655c0a29526d792f912355bb7807a /testing/perl-time-duration
parent909738e6e8efa790c2b09f3f1c5213de14469106 (diff)
downloadaports-a04f7eab13be1862e265e021316295f5ad335ff1.tar.bz2
aports-a04f7eab13be1862e265e021316295f5ad335ff1.tar.xz
testing/perl-time-duration: fix url fix license
Diffstat (limited to 'testing/perl-time-duration')
-rw-r--r--testing/perl-time-duration/APKBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/testing/perl-time-duration/APKBUILD b/testing/perl-time-duration/APKBUILD
index ff790afa8d..a1ead3e947 100644
--- a/testing/perl-time-duration/APKBUILD
+++ b/testing/perl-time-duration/APKBUILD
@@ -4,43 +4,34 @@
pkgname=perl-time-duration
_pkgreal=Time-Duration
pkgver=1.20
-pkgrel=0
+pkgrel=1
pkgdesc="rounded or exact English expression of durations"
-url="http://search.cpan.org/dist/Time-Duration/"
+url="https://metacpan.org/release/Time-Duration"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-cpancheckdepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}