aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-www-curl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-06-15 20:24:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-06-15 20:37:01 +0000
commit0470b70757dfec7864e17c2cc692e84f390fec12 (patch)
tree4ae6a2dd6b50e8a021bad0ac2368859d2a780ab7 /testing/perl-www-curl
parente79a2c38899fa6fa45be2203ae31660c25804967 (diff)
downloadaports-0470b70757dfec7864e17c2cc692e84f390fec12.tar.bz2
aports-0470b70757dfec7864e17c2cc692e84f390fec12.tar.xz
testing/perl-www-curl: rebuild against perl 5.26
Diffstat (limited to 'testing/perl-www-curl')
-rw-r--r--testing/perl-www-curl/APKBUILD9
-rw-r--r--testing/perl-www-curl/perl-5.26.patch12
2 files changed, 18 insertions, 3 deletions
diff --git a/testing/perl-www-curl/APKBUILD b/testing/perl-www-curl/APKBUILD
index 3e628068a9..cb4672f11a 100644
--- a/testing/perl-www-curl/APKBUILD
+++ b/testing/perl-www-curl/APKBUILD
@@ -4,7 +4,7 @@
pkgname=perl-www-curl
_pkgreal=WWW-Curl
pkgver=4.17
-pkgrel=2
+pkgrel=3
pkgdesc="Perl extension interface for libcurl"
url="http://search.cpan.org/dist/WWW-Curl/"
arch="all"
@@ -15,7 +15,9 @@ depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends curl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT/$_pkgreal-$pkgver.tar.gz
- WWW-Curl-4.17-RT117793.patch"
+ WWW-Curl-4.17-RT117793.patch
+ perl-5.26.patch
+ "
builddir="$srcdir/$_pkgreal-$pkgver"
@@ -42,4 +44,5 @@ package() {
}
sha512sums="bc7a75d0e23f5a77578fd7244b56a1e1b81d814993b90ac7132926f0d571232c4c95875bc615cb6239e424ae1d5481d27796efc5376bb0845d1da0ff1137c0d6 WWW-Curl-4.17.tar.gz
-d92cb37435d66867578818776f3ef64f4f6295515639d9bf860907ad28ca4109435c45174b49bdeb594a0cddafcc3f833c41d15d641eadfbbec598b77a1e90df WWW-Curl-4.17-RT117793.patch"
+d92cb37435d66867578818776f3ef64f4f6295515639d9bf860907ad28ca4109435c45174b49bdeb594a0cddafcc3f833c41d15d641eadfbbec598b77a1e90df WWW-Curl-4.17-RT117793.patch
+a0e91afecc23df532c1256255b202152597d00fd6e677d25a473fb0ce5e6d2a0be978298fee9dd73343765a1ad925afea5c73be458ace4311c733a14d0f55bae perl-5.26.patch"
diff --git a/testing/perl-www-curl/perl-5.26.patch b/testing/perl-www-curl/perl-5.26.patch
new file mode 100644
index 0000000000..428d93c32d
--- /dev/null
+++ b/testing/perl-www-curl/perl-5.26.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.PL b/Makefile.PL
+index bb852e4..dd6d228 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,6 +1,7 @@
+ # Makefile.PL for Perl module WWW::Curl
+ # Check out the README file for more information.
+
++BEGIN { push @INC, '.'; }
+ use inc::Module::Install;
+
+ name 'WWW-Curl';