aboutsummaryrefslogtreecommitdiffstats
path: root/testing/phoc/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-01-03 14:58:24 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-03 20:36:28 +0100
commit88388e77a00c2126410236e1233e7afe3c996b69 (patch)
treeab9ad8a694fba839c5b095359040f7f289710ea1 /testing/phoc/APKBUILD
parent231dd2352c771087448d50e22f86f2e722e9a8c1 (diff)
downloadaports-88388e77a00c2126410236e1233e7afe3c996b69.tar.bz2
aports-88388e77a00c2126410236e1233e7afe3c996b69.tar.xz
testing/phoc: new aport
Diffstat (limited to 'testing/phoc/APKBUILD')
-rw-r--r--testing/phoc/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/phoc/APKBUILD b/testing/phoc/APKBUILD
new file mode 100644
index 0000000000..a76305f5fc
--- /dev/null
+++ b/testing/phoc/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=phoc
+pkgver=0.1.5
+pkgrel=0
+pkgdesc="wlroots based Phone compositor for the Phosh shell"
+arch="all"
+url="https://source.puri.sm/Librem5/phoc"
+license="GPL-3.0-only"
+makedepends="meson ninja gobject-introspection-dev libinput-dev wayland-dev wayland-protocols libxkbcommon-dev wlroots-dev gnome-desktop-dev"
+source="$pkgname-$pkgver.tar.gz::https://source.puri.sm/Librem5/phoc/-/archive/v$pkgver/phoc-v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-v$pkgver"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja install -C output
+}
+sha512sums="fdd940d30ea818698689669f3dc1fc0103e8e1bb6d9740d777aa16119f0693357e100730df736aebabdd1c674b98fd41ebe61ccd8f339113c3f879d4868be05a phoc-0.1.5.tar.gz"