aboutsummaryrefslogtreecommitdiffstats
path: root/testing/phosh
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-01-03 15:11:31 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-03 20:36:28 +0100
commitf6d4ac39e81a751dfbe4c2249d3fe9256d42ed6b (patch)
tree6c73665ca8a1611aa884b7b3ea9cce78f4c78ba2 /testing/phosh
parent2565a35b68624f3828e8b696bbf66bdd82c98a7f (diff)
downloadaports-f6d4ac39e81a751dfbe4c2249d3fe9256d42ed6b.tar.bz2
aports-f6d4ac39e81a751dfbe4c2249d3fe9256d42ed6b.tar.xz
testing/phosh: new aport
Diffstat (limited to 'testing/phosh')
-rw-r--r--testing/phosh/APKBUILD49
-rw-r--r--testing/phosh/phosh.desktop11
-rw-r--r--testing/phosh/sm.puri.OSK0.desktop12
3 files changed, 72 insertions, 0 deletions
diff --git a/testing/phosh/APKBUILD b/testing/phosh/APKBUILD
new file mode 100644
index 0000000000..72a1e7f52a
--- /dev/null
+++ b/testing/phosh/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=phosh
+pkgver=0.1.6
+pkgrel=0
+pkgdesc="A shell PoC for the Librem5"
+# Blocked on s390x by gnome-session, gnome-settings-daemon, squeekboard and libhandy
+# Blocked on ppc64le by gnome-session
+arch="all !s390x !ppc64le"
+url="https://source.puri.sm/Librem5/phosh"
+license="GPL-3.0-only"
+depends="wayland-protocols phoc gnome-session bash dbus-x11 gnome-settings-daemon squeekboard libpulse"
+makedepends="gtk+3.0-dev meson ninja gnome-desktop-dev libhandy-dev gcr-dev upower-dev linux-pam-dev git cmake pulseaudio-dev networkmanager-dev polkit-elogind-dev libsecret-dev"
+subpackages="$pkgname-lang"
+source="
+ $pkgname-$pkgver.tar.xz::https://repo.pureos.net/pureos/pool/main/p/phosh/phosh_$pkgver.tar.xz
+ phosh.desktop
+ sm.puri.OSK0.desktop"
+options="!check" # Needs a running Wayland compositor
+builddir="$srcdir/$pkgname"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja test -C output
+}
+
+package() {
+ DESTDIR="$pkgdir/" ninja install -C output
+
+ install -D -m644 "$srcdir"/phosh.desktop \
+ "$pkgdir"/usr/share/wayland-sessions/phosh.desktop
+
+ install -D -m644 "$srcdir"/sm.puri.OSK0.desktop \
+ "$pkgdir"/usr/share/applications/sm.puri.OSK0.desktop
+
+}
+sha512sums="3599ef565cda1396a6b9940d88b9b5fd80c626104594d02cfd20fb60098bdc38484caa95b600439325b9c3155b79d752ea11439aa1e7ccd909563f308461761d phosh-0.1.6.tar.xz
+6644870edbbbc6b88d6e19f7771d81dba1a11066c2b34e4c22736db73a2dfd0d4909b4967503059c35385c5139a834a5c06a3c56b148ba1275d7f089c0c5f33c phosh.desktop
+f97019598323276cf97ae62f04b6245983198e04b228ddc605835ee46845d9b88c6890fb86e97e4bb6f1ad73361437d9ed18c91e81fe1284a88cdcb92d3fdc69 sm.puri.OSK0.desktop"
diff --git a/testing/phosh/phosh.desktop b/testing/phosh/phosh.desktop
new file mode 100644
index 0000000000..8445284511
--- /dev/null
+++ b/testing/phosh/phosh.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Phosh
+Name[en]=Phosh
+Comment=This session logs you into Phosh
+Comment[en]=This session logs in you into Phosh
+Exec=dbus-run-session /usr/bin/phosh
+TryExec=/usr/bin/phosh
+Icon=
+Type=Application
+X-DesktopNames=Phosh
+Keywords=launch;Phosh;desktop;session;
diff --git a/testing/phosh/sm.puri.OSK0.desktop b/testing/phosh/sm.puri.OSK0.desktop
new file mode 100644
index 0000000000..140b417d1e
--- /dev/null
+++ b/testing/phosh/sm.puri.OSK0.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Name=On-screen keyboard
+Comment=Default on-screen keyboard
+Exec=/usr/bin/osk-wayland
+Categories=GNOME;Core;
+OnlyShowIn=GNOME;
+NoDisplay=true
+X-GNOME-Autostart-Phase=Panel
+X-GNOME-Provides=inputmethod
+X-GNOME-Autostart-Notify=true
+X-GNOME-AutoRestart=true