aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-couchbase
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-05-01 23:41:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-02 01:53:18 +0200
commitd80b679a7d73b55df0f340da427f67f5c110061c (patch)
treed465669f036385df919a951d0ec2753f65d490c1 /testing/php7-couchbase
parent314904db8f5b354126987cb8ecf015c7e65eab9d (diff)
downloadaports-d80b679a7d73b55df0f340da427f67f5c110061c.tar.bz2
aports-d80b679a7d73b55df0f340da427f67f5c110061c.tar.xz
testing/php7-couchbase: build only for php7, cleanup and improve abuild
Diffstat (limited to 'testing/php7-couchbase')
-rw-r--r--testing/php7-couchbase/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-couchbase/APKBUILD b/testing/php7-couchbase/APKBUILD
new file mode 100644
index 0000000000..f1c7ec78e1
--- /dev/null
+++ b/testing/php7-couchbase/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Nathan Johnson <nathan@nathanjohnson.info>
+# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
+pkgname=php7-couchbase
+_pkgreal=couchbase
+pkgver=2.3.1
+pkgrel=0
+_phpver=${pkgname#php}
+_phpver=${_phpver%%-*}
+pkgdesc="PHP$_phpver extension for Couchbase"
+url="http://pecl.php.net/package/couchbase"
+arch="all"
+license="ASL-2.0"
+depends="php$_phpver-common php$_phpver-json"
+makedepends="php$_phpver-dev autoconf libcouchbase-dev zlib-dev"
+source="$pkgname-$pkgver.tgz::http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+options="!check"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+
+ phpize$_phpver
+ ./configure --prefix=/usr --with-php-config=php-config$_phpver
+ make
+}
+
+package() {
+ local confdir="$pkgdir/etc/php$_phpver/conf.d"
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ mkdir -p "$confdir"
+ echo "extension=$_pkgreal.so" > "$confdir"/$_pkgreal.ini
+}
+
+sha512sums="8a0003968d6ec7fec2961ea24c0677962c165cd0db4ebbcd3ec0d7ef50bd5e9788a4725ae4c18c5a558b30de44392c176d93d23980d489fd255546393a7a77f5 php7-couchbase-2.3.1.tgz"