aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-inotify
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-04-07 00:34:09 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-19 13:41:59 +0000
commitf4883acff0ea95d70dc6dd818b7a8815a74eef6e (patch)
treed027571ed3424bd15b4a9f719115add55c7cba9a /testing/php7-inotify
parent1960ac9a24142902ba380b987427b33849c05f1d (diff)
downloadaports-f4883acff0ea95d70dc6dd818b7a8815a74eef6e.tar.bz2
aports-f4883acff0ea95d70dc6dd818b7a8815a74eef6e.tar.xz
testing/php7-inotify: PHP7 Inotify package
Diffstat (limited to 'testing/php7-inotify')
-rw-r--r--testing/php7-inotify/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-inotify/APKBUILD b/testing/php7-inotify/APKBUILD
new file mode 100644
index 0000000000..ba7d8d043c
--- /dev/null
+++ b/testing/php7-inotify/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-inotify
+_pkgreal=inotify
+pkgver=2.0.0
+_pkgver=${pkgver}
+pkgrel=0
+pkgdesc="Inotify bindings for PHP"
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php7-dev autoconf"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/70_$_pkgreal.ini
+}
+
+md5sums="f7a951b3c66d08f5e7889479f5fc7564 inotify-2.0.0.tgz"
+sha256sums="d044a89d26bbaa110f34f182b1c92ab5eb09768096bacf3d837d7e49ac045107 inotify-2.0.0.tgz"
+sha512sums="0547fdafd8177d41c2a92251cd85f046959ec8594236dc3d14396df0119a78cc6811973b641b95d1036b4325f9e97f0f9e9b181ae1dea79fc343f01777b6966d inotify-2.0.0.tgz"