aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-memcached
diff options
context:
space:
mode:
authorAleksi Johansson <aleksi.johansson@wunderkraut.com>2016-09-12 17:33:59 +0300
committerJakub Jirutka <jakub@jirutka.cz>2016-09-29 00:06:50 +0200
commit990bd522239ce3a77ed4b88e039379c32dce89c1 (patch)
treec25da00123767ba1915166ad0047ed4722293d1b /testing/php7-memcached
parentfc0d9db801f1fe8c502ebae332c798ec99bcfa20 (diff)
downloadaports-990bd522239ce3a77ed4b88e039379c32dce89c1.tar.bz2
aports-990bd522239ce3a77ed4b88e039379c32dce89c1.tar.xz
testing/php7-memcached: move from unmaintained and fix the abuild
Diffstat (limited to 'testing/php7-memcached')
-rw-r--r--testing/php7-memcached/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/testing/php7-memcached/APKBUILD b/testing/php7-memcached/APKBUILD
new file mode 100644
index 0000000000..0a7fd857e0
--- /dev/null
+++ b/testing/php7-memcached/APKBUILD
@@ -0,0 +1,42 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-memcached
+_pkgreal=memcached
+_pkgrepo=php-memcached
+_pkgbranch=php7
+_pkgcommit=583ecd68faec886ac9233277531f78fb6e2043c7
+pkgver=3.0_pre20160808
+pkgrel=0
+pkgdesc="PHP extension for interfacing with memcached via libmemcached library"
+url="https://github.com/$_pkgrepo-dev/$_pkgrepo/tree/$_pkgbranch"
+arch="all"
+license="PHP"
+depends="php7-session"
+pecldepends="php7-dev autoconf zlib-dev"
+makedepends="$pecldepends libmemcached-dev cyrus-sasl-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgrepo-dev/$_pkgrepo/archive/$_pkgcommit.tar.gz"
+
+builddir="$srcdir"/$_pkgrepo-$_pkgcommit
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure \
+ --prefix=/usr \
+ --disable-memcached-sasl \
+ --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir/" install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/20_$_pkgreal.ini
+}
+
+md5sums="081d43caf5a5cb4f70348280014e3da9 php7-memcached-3.0_pre20160808.tar.gz"
+sha256sums="a770003ebc6bb2a4976dd9ebaa9304552575c5ed9e0c998d941bdd087fee106e php7-memcached-3.0_pre20160808.tar.gz"
+sha512sums="3e38885bb43aa26a69d101ad890fe73a4f545c76210450da25c067699b06c2ce7c94f900f8956ff38b5d68376bc2fadfd8c18e32a83df907a3437698c1c6ae84 php7-memcached-3.0_pre20160808.tar.gz"