aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-mongodb
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-02-23 06:09:33 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-02-23 15:21:07 +0100
commit2de8ed5a460f73ee852a0f9dc5e628fda4ae944b (patch)
tree587831107891c2da0ae9e17ee9cd5ef8c0112a06 /testing/php7-mongodb
parent2e3366107dd4375e20555259bf16cd2ee722f5c5 (diff)
downloadaports-2de8ed5a460f73ee852a0f9dc5e628fda4ae944b.tar.bz2
aports-2de8ed5a460f73ee852a0f9dc5e628fda4ae944b.tar.xz
testing/php7-mongodb: modernize
Diffstat (limited to 'testing/php7-mongodb')
-rw-r--r--testing/php7-mongodb/APKBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/testing/php7-mongodb/APKBUILD b/testing/php7-mongodb/APKBUILD
index 1fdbe8703d..4421d221c9 100644
--- a/testing/php7-mongodb/APKBUILD
+++ b/testing/php7-mongodb/APKBUILD
@@ -19,17 +19,16 @@ options="!check" # tests requires additional dependencies (vagrant)
_builddir="$srcdir"/$_pkgreal-$_pkgver
build() {
cd "$_builddir"
- phpize7 || return 1
+ phpize7
./configure --prefix=/usr \
- --with-php-config=/usr/bin/php-config7 \
- || return 1
- make || return 1
+ --with-php-config=/usr/bin/php-config7
+ make
}
package() {
cd "$_builddir"
- make INSTALL_ROOT="$pkgdir/" install || return 1
- install -d "$pkgdir"/etc/php7/conf.d || return 1
+ make INSTALL_ROOT="$pkgdir/" install
+ install -d "$pkgdir"/etc/php7/conf.d
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
}