aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-swoole
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-03-24 13:52:33 +0200
committerAndy Postnikov <apostnikov@gmail.com>2019-03-24 15:36:16 +0200
commit0c377b83868fecc7db71557d872046739540b408 (patch)
treef190c62e6616853406cccbf8cfd0d3e4dd4e2c98 /testing/php7-pecl-swoole
parentd880204f7b79e2820f0b7d2b70616fa2e461e3d4 (diff)
downloadaports-0c377b83868fecc7db71557d872046739540b408.tar.bz2
aports-0c377b83868fecc7db71557d872046739540b408.tar.xz
testing/php7-pecl-swoole: add arm patch to build aarch64 and arm*
Diffstat (limited to 'testing/php7-pecl-swoole')
-rw-r--r--testing/php7-pecl-swoole/APKBUILD10
-rw-r--r--testing/php7-pecl-swoole/arch.patch16
2 files changed, 22 insertions, 4 deletions
diff --git a/testing/php7-pecl-swoole/APKBUILD b/testing/php7-pecl-swoole/APKBUILD
index baf7f28dc0..1bc9244b89 100644
--- a/testing/php7-pecl-swoole/APKBUILD
+++ b/testing/php7-pecl-swoole/APKBUILD
@@ -2,14 +2,15 @@
pkgname=php7-pecl-swoole
_pkgreal=swoole
pkgver=4.3.1
-pkgrel=0
+pkgrel=1
pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP."
url="https://pecl.php.net/package/swoole"
-arch="x86_64" # https://github.com/swoole/swoole-src/issues/2181
+arch="all !s390x !ppc64le !x86" # https://github.com/swoole/swoole-src/issues/2181
license="Apache-2.0"
depends="php7-openssl php7-sockets"
makedepends="php7-dev autoconf re2c openssl-dev nghttp2-dev"
-source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz
+ arch.patch"
builddir="$srcdir"/$_pkgreal-$pkgver
subpackages="$pkgname-dev"
@@ -37,4 +38,5 @@ package() {
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini
}
-sha512sums="63eb47a7ee5c298ec2f2a7ed1d5fdc0ad23d680c86879ced48a541b511ba93501a4eedbc46c40382a131e482d1407a89a987c87c3b3de6b641b982b3ed976dc3 swoole-4.3.1.tgz"
+sha512sums="63eb47a7ee5c298ec2f2a7ed1d5fdc0ad23d680c86879ced48a541b511ba93501a4eedbc46c40382a131e482d1407a89a987c87c3b3de6b641b982b3ed976dc3 swoole-4.3.1.tgz
+5e5e8cc787bfdaab7ecb450fd40b52d71526a4e479c67f8fb62326ec988b408bbcb8d23cebcec0bc5991131078f53272f37f4e21942ba773b9c8c73cce8c22ab arch.patch"
diff --git a/testing/php7-pecl-swoole/arch.patch b/testing/php7-pecl-swoole/arch.patch
new file mode 100644
index 0000000000..802af23a33
--- /dev/null
+++ b/testing/php7-pecl-swoole/arch.patch
@@ -0,0 +1,16 @@
+diff --git a/config.m4 b/config.m4
+index 657072fd..84415bf4 100644
+--- a/config.m4
++++ b/config.m4
+@@ -526,9 +526,9 @@ if test "$PHP_SWOOLE" != "no"; then
+
+ AS_CASE([$host_cpu],
+ [x86_64*], [SW_CPU="x86_64"],
+- [x86*], [SW_CPU="x86"],
++ [i586*], [SW_CPU="x86"],
+ [arm*], [SW_CPU="arm"],
+- [arm64*], [SW_CPU="arm64"],
++ [aarch64*], [SW_CPU="arm64"],
+ [
+ SW_NO_USE_ASM_CONTEXT="yes"
+ AC_DEFINE([SW_NO_USE_ASM_CONTEXT], 1, [use boost asm context?])