aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-swoole
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-04-16 19:50:34 +0300
committerAndy Postnikov <apostnikov@gmail.com>2019-04-16 20:00:22 +0300
commit9d4584665b92decc72ab2efdab6f51ae0925362b (patch)
treee1ab0c5df7c880d0e630255fae95d0f541f3b643 /testing/php7-pecl-swoole
parent321469f5b874d54192a77376af3e2fe20f32a9a1 (diff)
downloadaports-9d4584665b92decc72ab2efdab6f51ae0925362b.tar.bz2
aports-9d4584665b92decc72ab2efdab6f51ae0925362b.tar.xz
testing/php7-pecl-swoole: upgrade to 4.3.2
Diffstat (limited to 'testing/php7-pecl-swoole')
-rw-r--r--testing/php7-pecl-swoole/APKBUILD11
-rw-r--r--testing/php7-pecl-swoole/arch.patch16
2 files changed, 4 insertions, 23 deletions
diff --git a/testing/php7-pecl-swoole/APKBUILD b/testing/php7-pecl-swoole/APKBUILD
index 1bc9244b89..a34f8a5621 100644
--- a/testing/php7-pecl-swoole/APKBUILD
+++ b/testing/php7-pecl-swoole/APKBUILD
@@ -1,16 +1,15 @@
# Maintainer: Andy Postnikov <apostnikov@gmail.com>
pkgname=php7-pecl-swoole
_pkgreal=swoole
-pkgver=4.3.1
-pkgrel=1
+pkgver=4.3.2
+pkgrel=0
pkgdesc="Event-driven asynchronous and concurrent networking engine with high performance for PHP."
url="https://pecl.php.net/package/swoole"
arch="all !s390x !ppc64le !x86" # https://github.com/swoole/swoole-src/issues/2181
license="Apache-2.0"
depends="php7-openssl php7-sockets"
makedepends="php7-dev autoconf re2c openssl-dev nghttp2-dev"
-source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz
- arch.patch"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir"/$_pkgreal-$pkgver
subpackages="$pkgname-dev"
@@ -26,7 +25,6 @@ build() {
}
check() {
- cd "$builddir"
# needs extra services to test all suite
php7 -d extension="$builddir"/modules/swoole.so --ri swoole
}
@@ -38,5 +36,4 @@ package() {
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini
}
-sha512sums="63eb47a7ee5c298ec2f2a7ed1d5fdc0ad23d680c86879ced48a541b511ba93501a4eedbc46c40382a131e482d1407a89a987c87c3b3de6b641b982b3ed976dc3 swoole-4.3.1.tgz
-5e5e8cc787bfdaab7ecb450fd40b52d71526a4e479c67f8fb62326ec988b408bbcb8d23cebcec0bc5991131078f53272f37f4e21942ba773b9c8c73cce8c22ab arch.patch"
+sha512sums="ebac425ba3ec8f865f0cbcfe304d2093644ec00f3424ddf640b37f69af70943f4cdf6b21789856ddc6d8a94d28aad61af4e328995cf70f46d97831bad6880a29 swoole-4.3.2.tgz"
diff --git a/testing/php7-pecl-swoole/arch.patch b/testing/php7-pecl-swoole/arch.patch
deleted file mode 100644
index 802af23a33..0000000000
--- a/testing/php7-pecl-swoole/arch.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/config.m4 b/config.m4
-index 657072fd..84415bf4 100644
---- a/config.m4
-+++ b/config.m4
-@@ -526,9 +526,9 @@ if test "$PHP_SWOOLE" != "no"; then
-
- AS_CASE([$host_cpu],
- [x86_64*], [SW_CPU="x86_64"],
-- [x86*], [SW_CPU="x86"],
-+ [i586*], [SW_CPU="x86"],
- [arm*], [SW_CPU="arm"],
-- [arm64*], [SW_CPU="arm64"],
-+ [aarch64*], [SW_CPU="arm64"],
- [
- SW_NO_USE_ASM_CONTEXT="yes"
- AC_DEFINE([SW_NO_USE_ASM_CONTEXT], 1, [use boost asm context?])