aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-xlswriter/APKBUILD
diff options
context:
space:
mode:
authorviest <dev@service.viest.me>2020-01-06 18:13:54 +0800
committerAndy Postnikov <apostnikov@gmail.com>2020-01-06 21:14:15 +0200
commit45c5a77c2a0634fe134de3d82d441b41c9d69867 (patch)
treee3a592714cd0f36fadd268b3c1c9f259d34b8ad6 /testing/php7-pecl-xlswriter/APKBUILD
parentd8258bd0cf507a3a42b617b813b7055e056afc34 (diff)
downloadaports-45c5a77c2a0634fe134de3d82d441b41c9d69867.tar.bz2
aports-45c5a77c2a0634fe134de3d82d441b41c9d69867.tar.xz
testing/php7-pecl-xlswriter: upgrade to 1.3.3.2
Diffstat (limited to 'testing/php7-pecl-xlswriter/APKBUILD')
-rw-r--r--testing/php7-pecl-xlswriter/APKBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/testing/php7-pecl-xlswriter/APKBUILD b/testing/php7-pecl-xlswriter/APKBUILD
index fd6d80eb47..7d2eb4aef1 100644
--- a/testing/php7-pecl-xlswriter/APKBUILD
+++ b/testing/php7-pecl-xlswriter/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: viest <dev@service.viest.me>
pkgname="php7-pecl-xlswriter"
_pkgreal=xlswriter
-pkgver="1.3.1"
+pkgver="1.3.3.2"
pkgrel=0
pkgdesc="A PHP Extension for creating and reader XLSX files. "
url="https://pecl.php.net/package/xlswriter"
@@ -14,22 +14,21 @@ source="$pkgname-$pkgver.tar.gz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir"/$_pkgreal-$pkgver
build() {
- phpize7
- ./configure \
- --enable-reader \
- --prefix=/usr \
- --with-php-config=/usr/bin/php-config7
- make
+ phpize7
+ ./configure \
+ --prefix=/usr \
+ --with-php-config=/usr/bin/php-config7
+ make
}
check() {
- make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {
- make INSTALL_ROOT="$pkgdir/" install
- install -d "$pkgdir"/etc/php7/conf.d
- echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+ make INSTALL_ROOT="$pkgdir/" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
}
-sha512sums="9d14c9ae0d7a757fba9de4a4d241914778ce106d82f5349c239e2954bc95744714c5e7e87cfc87e28a733dbf917384e3b1afe1bfedf46ec94f5ce5dad963a5f7 php7-pecl-xlswriter-1.3.1.tar.gz"
+sha512sums="a04606fac1419d7180aa7e05d9587bedfb9ac08ead907113d2e6023e6121855c98a0b991cb7cebc4493e004ca44fcc650cb593058dd39860beed5797d73b88d4 php7-pecl-xlswriter-1.3.3.2.tar.gz"