aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-redis
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-06-18 15:22:25 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-06-18 15:22:25 +0200
commit84c62249810b69b10e4b820b7ea0caeb95503048 (patch)
tree245d57c123590e720a78ba9dabe756a21b5a5116 /testing/php7-redis
parent16bf61df0f34abbe376dfd0fd6b53719310964a9 (diff)
downloadaports-84c62249810b69b10e4b820b7ea0caeb95503048.tar.bz2
aports-84c62249810b69b10e4b820b7ea0caeb95503048.tar.xz
testing/php7-redis: fix package source and checksums
Diffstat (limited to 'testing/php7-redis')
-rw-r--r--testing/php7-redis/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/testing/php7-redis/APKBUILD b/testing/php7-redis/APKBUILD
index 9c77f43702..59d3824eaa 100644
--- a/testing/php7-redis/APKBUILD
+++ b/testing/php7-redis/APKBUILD
@@ -3,11 +3,13 @@
pkgname=php7-redis
_pkgreal=redis
_pkgrepo=phpredis
-_pkgbranch=php7
pkgver=3.0.0
-pkgrel=0
+# There's no tag for php7 variant; this is SHA of the commit in the php7 branch
+# with version bump.
+_pkgrev=64479400a0b3c7b8b006e5de905836e4d764a763
+pkgrel=1
pkgdesc="PHP extension for interfacing with Redis (Dev PHP7)"
-url="https://github.com/$_pkgrepo/$_pkgrepo/tree/$_pkgbranch"
+url="https://github.com/$_pkgrepo/$_pkgrepo/tree/php7"
arch="x86_64 armhf"
license="PHP"
depends="php7-session"
@@ -15,8 +17,8 @@ pecldepends="php7-dev autoconf"
makedepends="$pecldepends"
install=""
subpackages=""
-source="$_pkgrepo-$pkgver.tar.gz::https://github.com/$_pkgrepo/$_pkgrepo/archive/$_pkgbranch.tar.gz"
-builddir="$srcdir/$_pkgrepo-$_pkgbranch"
+source="$_pkgrepo-$_pkgrev.tar.gz::https://github.com/$_pkgrepo/$_pkgrepo/archive/$_pkgrev.tar.gz"
+builddir="$srcdir/$_pkgrepo-$_pkgrev"
build() {
cd "$builddir"
@@ -32,6 +34,6 @@ package() {
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/20_$_pkgreal.ini
}
-md5sums="4ceb9fcfaf005f12e49c7410a4620f4c phpredis-3.0.0.tar.gz"
-sha256sums="030997370bb1906793989c89550d9cafd4fa35dccbad7040b2339301aa961dba phpredis-3.0.0.tar.gz"
-sha512sums="51f9492189443b851ec721cb0285a82426130162ab8ce2cd7ea26b1b7757a8c893d00b91f4dbb8dd1fd6bcef828ca98c4378c24faf59afa8df5b9c92a81798d5 phpredis-3.0.0.tar.gz"
+md5sums="b9715c6b71e1461e06f42d52aa9d3672 phpredis-64479400a0b3c7b8b006e5de905836e4d764a763.tar.gz"
+sha256sums="b1dd5138030ee7dfb71e15b6a08f7fae7f757c1b04797eeb409a142c6a2cc400 phpredis-64479400a0b3c7b8b006e5de905836e4d764a763.tar.gz"
+sha512sums="9ab5efbf2cd87a2ce7fca7088001951bd07ab85ceafff4953af4994086f5934eb36b19763045bb85d479432cd0803254202072faaf11fbdccec82a7c4a8d2c18 phpredis-64479400a0b3c7b8b006e5de905836e4d764a763.tar.gz"