aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-tideways_xhprof
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-02-13 22:37:24 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-03-06 01:52:04 +0200
commit8e0f8a81f508a6e1ac2387e60f2bbea9f073a7c0 (patch)
treee250a5bc8e88f7ef4bde36a8ae4c0e73656a430f /testing/php7-tideways_xhprof
parent1f6a8003df6c2ab8d4c3e4ee89dcc58643f829b0 (diff)
downloadaports-8e0f8a81f508a6e1ac2387e60f2bbea9f073a7c0.tar.bz2
aports-8e0f8a81f508a6e1ac2387e60f2bbea9f073a7c0.tar.xz
testing/php7-tideways_xhprof: new aport
Diffstat (limited to 'testing/php7-tideways_xhprof')
-rw-r--r--testing/php7-tideways_xhprof/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/php7-tideways_xhprof/APKBUILD b/testing/php7-tideways_xhprof/APKBUILD
new file mode 100644
index 0000000000..990ceddc4c
--- /dev/null
+++ b/testing/php7-tideways_xhprof/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Andy Postnikov <apostnikov@gmail.com>
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php7-tideways_xhprof
+_pkgext=tideways_xhprof
+_pkgreal=php-xhprof-extension
+pkgver=5.0_beta2
+_pkgver=${pkgver/_/-}
+pkgrel=0
+pkgdesc="Modern XHProf compatible Profiler for PHP 7 https://tideways.io"
+url="https://github.com/tideways/php-xhprof-extension"
+arch="all"
+license="Apache-2.0"
+depends="php7"
+makedepends="php7-dev autoconf"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/tideways/php-xhprof-extension/archive/v$_pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgreal-$_pkgver
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure --prefix=/usr \
+ --with-php-config=/usr/bin/php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir/" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgext.so" > "$pkgdir"/etc/php7/conf.d/$_pkgext.ini
+}
+
+sha512sums="1e42589b81f39272cf62a058e1ecd82532b076bebe583d13b797d448891ff615aedf1e990785fbba7302daa34a977bf748cf2deaaf4fd334af800a556849334c php7-tideways_xhprof-5.0_beta2.tar.gz"