aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-tideways_xhprof
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-10 18:06:48 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-10 18:07:29 +0100
commitf2744cee726dfd8c2568b666940ed673ef3a3756 (patch)
treeeb4259c06e18bd0e4ed3ca7cfd7b3735df88a7b3 /testing/php7-tideways_xhprof
parent2ce590a52d57286b1f4d599cd37a1ea5826eb14c (diff)
downloadaports-f2744cee726dfd8c2568b666940ed673ef3a3756.tar.bz2
aports-f2744cee726dfd8c2568b666940ed673ef3a3756.tar.xz
testing/php7-tideways_xhprof: disable on aarch64 due to build failure
gcc -DZEND_ENABLE_STATIC_TSRMLS_CACHE=1 -I. -I/home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2 -DPHP_ATOM_INC -I/home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/include -I/home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/main -I/home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2 -I/usr/include/php7 -I/usr/include/php7/main -I/usr/include/php7/TSRM -I/usr/include/php7/Zend -I/usr/include/php7/ext -I/usr/include/php7/ext/date/lib -Os -DHAVE_CONFIG_H -Os -c /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/tideways_xhprof.c -fPIC -DPIC -o .libs/tideways_xhprof.o In file included from /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/tracing.h:1:0, from /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/tracing.c:11: /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/tracing.c: In function 'tracing_enter_root_frame': /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/timer.h:79:13: error: impossible constraint in 'asm' asm volatile("rdtsc" : "=a" (a), "=d" (d)); ^~~ /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/timer.h:79:13: error: impossible constraint in 'asm' asm volatile("rdtsc" : "=a" (a), "=d" (d)); ^~~ In file included from /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/tracing.h:1:0, from /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/tideways_xhprof.c:13: /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/tideways_xhprof.c: In function 'tideways_xhprof_execute_ex': /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/timer.h:79:13: error: impossible constraint in 'asm' asm volatile("rdtsc" : "=a" (a), "=d" (d)); ^~~ /home/buildozer/aports/testing/php7-tideways_xhprof/src/php-xhprof-extension-5.0-beta2/timer.h:79:13: error: impossible constraint in 'asm' asm volatile("rdtsc" : "=a" (a), "=d" (d)); ^~~ make: *** [Makefile:196: tracing.lo] Error 1
Diffstat (limited to 'testing/php7-tideways_xhprof')
-rw-r--r--testing/php7-tideways_xhprof/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/testing/php7-tideways_xhprof/APKBUILD b/testing/php7-tideways_xhprof/APKBUILD
index 0ea7644dbb..2d5794817f 100644
--- a/testing/php7-tideways_xhprof/APKBUILD
+++ b/testing/php7-tideways_xhprof/APKBUILD
@@ -8,7 +8,7 @@ _pkgver=${pkgver/_/-}
pkgrel=0
pkgdesc="Modern XHProf compatible Profiler for PHP 7"
url="http://tideways.io"
-arch="all !armhf" # fails to build
+arch="all !armhf !aarch64" # fails to build
license="Apache-2.0"
depends="php7"
makedepends="php7-dev autoconf"