aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-timezonedb
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2017-12-03 18:50:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-12-04 13:48:39 +0100
commitb12bc103005ea4d64960f538bd0c3afe8cb44076 (patch)
tree1c96ea4f6d11674e39380ab79552096a2a3ad04e /testing/php7-timezonedb
parent0e5a0149f0012000a005033875048ac6c95e612b (diff)
downloadaports-b12bc103005ea4d64960f538bd0c3afe8cb44076.tar.bz2
aports-b12bc103005ea4d64960f538bd0c3afe8cb44076.tar.xz
testing/php7-timezonedb: upgrade to 2017.3 and modernize abuild
Diffstat (limited to 'testing/php7-timezonedb')
-rw-r--r--testing/php7-timezonedb/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/testing/php7-timezonedb/APKBUILD b/testing/php7-timezonedb/APKBUILD
index d41d2d85a8..a2a400246c 100644
--- a/testing/php7-timezonedb/APKBUILD
+++ b/testing/php7-timezonedb/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
pkgname=php7-timezonedb
_pkgreal=timezonedb
-pkgver=2017.2
-pkgrel=1
+pkgver=2017.3
+pkgrel=0
pkgdesc="Timezone Database to be used with PHP's date and time functions."
url="http://pecl.php.net/package/$_pkgreal"
arch="all"
@@ -15,21 +15,20 @@ subpackages=""
source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir"/$_pkgreal-$pkgver
+options="!check" # upstream does not provide tests yet
build() {
cd "$builddir"
- phpize7 || return 1
- ./configure --prefix=/usr --with-php-config=php-config7 || return 1
- make || return 1
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
}
package() {
cd "$builddir"
- make INSTALL_ROOT="$pkgdir"/ install || return 1
- install -d "$pkgdir"/etc/php7/conf.d || return 1
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/php7/conf.d
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/40_$_pkgreal.ini
}
-md5sums="f3781f2487037e33f8a5543781301c0e timezonedb-2017.2.tgz"
-sha256sums="e96ea4045a2886d68d15ad64e8d0ace1dd5287b08226e422bc7befb27944927a timezonedb-2017.2.tgz"
-sha512sums="767b24c406b2599aefb67e97bb96114e51f12a5f53397ce3607a8030e10320348705ad28cc2a717002d9c1112f7fe97041201e6a09e5c773926543459ff1e65f timezonedb-2017.2.tgz"
+sha512sums="5f6064064a71bf973f7581d452cad909ca2203c4c8773ca7cb31307c3cbe63613adf972cfc6c7b0800215018e2fb3c4b7a2d7d0df171243319ab63047e9099fc timezonedb-2017.3.tgz"