aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-timezonedb
diff options
context:
space:
mode:
authorFabio da Silva Ribeiro <silva.ribeiro@dafiti.com.br>2016-04-07 08:09:35 -0300
committerTimo Teräs <timo.teras@iki.fi>2016-04-19 13:44:33 +0000
commitbc1f462ab9cc48b81127db0e246063040d740c8b (patch)
tree74f86b6e4ef0d64cc9fd4ea73955f0b351a418ba /testing/php7-timezonedb
parentaa29dcd0db4b8e388a9c507821f8a9e92ae99521 (diff)
downloadaports-bc1f462ab9cc48b81127db0e246063040d740c8b.tar.bz2
aports-bc1f462ab9cc48b81127db0e246063040d740c8b.tar.xz
testing/php7-timezonedb: PHP7 Timezonedb package
Diffstat (limited to 'testing/php7-timezonedb')
-rw-r--r--testing/php7-timezonedb/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-timezonedb/APKBUILD b/testing/php7-timezonedb/APKBUILD
new file mode 100644
index 0000000000..2789fb0f81
--- /dev/null
+++ b/testing/php7-timezonedb/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-timezonedb
+_pkgreal=timezonedb
+pkgver=2016.3
+_pkgver=${pkgver}
+pkgrel=0
+pkgdesc="Timezone Database to be used with PHP's date and time functions."
+url="http://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=
+pecldepends="php7-dev autoconf"
+makedepends="$pecldepends"
+install=""
+subpackages=""
+source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+
+builddir="$srcdir"/$_pkgreal-$_pkgver
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure --prefix=/usr --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/40_$_pkgreal.ini
+}
+
+md5sums="552c1db6a39ab241c5d634b5380bfc38 timezonedb-2016.3.tgz"
+sha256sums="a87f2f11055355b9df4941fe6da576217f8aaa4b620d75603dd143dc243646db timezonedb-2016.3.tgz"
+sha512sums="84a65ccbdd0d7ade5a984ca93c8688b23e08c2c7550c824627e05aedc65837b977a5c43caaac121ea2ff0ddcde71d2b82db8ec1048efd52597d004110f42c7a1 timezonedb-2016.3.tgz"