aboutsummaryrefslogtreecommitdiffstats
path: root/testing/picotts/APKBUILD
diff options
context:
space:
mode:
authorEric Trombly <etrombly@yahoo.com>2019-11-05 14:32:15 -0600
committerLeo <thinkabit.ukim@gmail.com>2019-12-26 15:09:13 +0100
commitde347da9309d222ca4a6884da1d3e10b26387e83 (patch)
treeaaa0758bf6fd579a53c9e8b6e581d4520492a3b5 /testing/picotts/APKBUILD
parent881a54816216d011d1d27286df2693851c86caef (diff)
downloadaports-de347da9309d222ca4a6884da1d3e10b26387e83.tar.bz2
aports-de347da9309d222ca4a6884da1d3e10b26387e83.tar.xz
testing/picotts: new aport
https://github.com/naggety/picotts Pico TTS: text to speech voice synthesizer from SVox
Diffstat (limited to 'testing/picotts/APKBUILD')
-rw-r--r--testing/picotts/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/testing/picotts/APKBUILD b/testing/picotts/APKBUILD
new file mode 100644
index 0000000000..06faa84cb0
--- /dev/null
+++ b/testing/picotts/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Eric Trombly <etrombly@yahoo.com>
+# Maintainer:
+pkgname=picotts
+pkgver=0.1
+pkgrel=0
+pkgdesc="Pico TTS: text to speech voice synthesizer from SVox"
+url="https://github.com/naggety/picotts"
+arch="all"
+license="Apache-2.0"
+makedepends="popt-dev autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-libs"
+source="https://github.com/naggety/picotts/archive/e3ba46009ee868911fa0b53db672a55f9cc13b1c.zip"
+builddir="$srcdir/picotts-e3ba46009ee868911fa0b53db672a55f9cc13b1c/pico"
+
+prepare() {
+ default_prepare
+ ./autogen.sh
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="e65b46aaeb65cf151e94b8740d6ac9a691613de973cb7d10e1a39b71ef7dead53525602209c99dfefbcb5abed3520321f45e9f324efae7b28af72a10e3f06ba5 e3ba46009ee868911fa0b53db672a55f9cc13b1c.zip"