aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pixz/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-02-19 19:09:17 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-02-19 19:11:00 +0000
commitbb078ac5e4aae00005fb1db57f5f4e73d6096d4e (patch)
treedbf2c8499d566959e2a4b32378a742f18e018889 /testing/pixz/APKBUILD
parentf934fae50830dfaa9191262bfc3dce8907dccf39 (diff)
downloadaports-bb078ac5e4aae00005fb1db57f5f4e73d6096d4e.tar.bz2
aports-bb078ac5e4aae00005fb1db57f5f4e73d6096d4e.tar.xz
testing/pixz: new aport
Diffstat (limited to 'testing/pixz/APKBUILD')
-rw-r--r--testing/pixz/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/pixz/APKBUILD b/testing/pixz/APKBUILD
new file mode 100644
index 0000000000..7469cab963
--- /dev/null
+++ b/testing/pixz/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer:
+pkgname=pixz
+pkgver=1.0.6
+pkgrel=0
+pkgdesc="Parallel, indexed xz compressor"
+url="https://github.com/vasi/pixz"
+arch="all"
+license="BSD-2-Clause"
+depends=""
+makedepends="libarchive-dev xz-dev
+ automake autoconf libtool
+ "
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/vasi/pixz/releases/download/v$pkgver/pixz-$pkgver.tar.xz
+ 0001-use-posix-shell-for-tests.patch
+ "
+builddir="$srcdir/pixz-$pkgver"
+
+build() {
+ cd "$builddir"
+ autoreconf -vif
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="361a8d8b736c350e4e3fd19b5d36777129a087eb81439d05edc08f9378938583bef8fc70e440ffd22efb6dad1f6494c6c3e532d7dd1ab12c9350b6078aa993d7 pixz-1.0.6.tar.xz
+f9333adaefb8f6bae4bc1841185f6289b362895c46702e213392aae4954ec2fe81d169a21fcd5eec2d0f96d243ec4add1f8ae89dc6480f603231c954da47d4ed 0001-use-posix-shell-for-tests.patch"