aboutsummaryrefslogtreecommitdiffstats
path: root/testing/platformio-core
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-01-13 15:55:52 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-01-13 15:56:24 +0100
commit2305acbbe0883d010691644e320b08bb7301644f (patch)
treeacdff1d299160041afbcd40d95719938d81cc798 /testing/platformio-core
parent333b4490af22ea23603bd96e2357f9c92740f779 (diff)
downloadaports-2305acbbe0883d010691644e320b08bb7301644f.tar.bz2
aports-2305acbbe0883d010691644e320b08bb7301644f.tar.xz
testing/platformio-core: rename and upgrade to 3.2.1
Diffstat (limited to 'testing/platformio-core')
-rw-r--r--testing/platformio-core/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/platformio-core/APKBUILD b/testing/platformio-core/APKBUILD
new file mode 100644
index 0000000000..9bc92d36c5
--- /dev/null
+++ b/testing/platformio-core/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=platformio-core
+pkgver=3.2.1
+pkgrel=0
+pkgdesc="An open source ecosystem for IoT development"
+url="http://platformio.org"
+arch="all"
+license="ASL 2.0"
+depends="python py-bottle py-click5 py-lockfile py-serial
+ py-requests py-colorama py-semanticversion"
+makedepends="python-dev py-setuptools"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/platformio/platformio-core/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr \
+ --root="$pkgdir" || return 1
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
+ install -m644 CONTRIBUTING.md README.rst HISTORY.rst \
+ "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+
+}
+
+md5sums="dc2a1aedef6a225a42722abe104d315d platformio-core-3.2.1.tar.gz"
+sha256sums="5a85e60afc28b4ee04b43efd90c77f69b6c6ff96829e1b8750aa52143bca6eb2 platformio-core-3.2.1.tar.gz"
+sha512sums="4edac4cfcfe0e51d15db319d5bde95fcbf952d9a3ecb8da34ff7fd00177255658493a5e8fda118c92dce68a039b829e63824813ef77c4ca106d7346bfe3ce348 platformio-core-3.2.1.tar.gz"