aboutsummaryrefslogtreecommitdiffstats
path: root/testing/portmidi/03_pm_test_Makefile.patch
diff options
context:
space:
mode:
authorTaner Tas <taner76@gmail.com>2018-02-21 16:33:34 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-02-28 12:53:05 +0000
commit24cdbb59afb3e0141401a09cc98c918283ccdc49 (patch)
treec18c934ec904845e8c95d4f52137960751faeec0 /testing/portmidi/03_pm_test_Makefile.patch
parent478a4a468ecf31c263b6c76dfab0f2332bc3365f (diff)
downloadaports-24cdbb59afb3e0141401a09cc98c918283ccdc49.tar.bz2
aports-24cdbb59afb3e0141401a09cc98c918283ccdc49.tar.xz
testing/portmidi: new aport
http://portmedia.sourceforge.net/ PortMidi is a platform independent library for MIDI input/output.
Diffstat (limited to 'testing/portmidi/03_pm_test_Makefile.patch')
-rw-r--r--testing/portmidi/03_pm_test_Makefile.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/portmidi/03_pm_test_Makefile.patch b/testing/portmidi/03_pm_test_Makefile.patch
new file mode 100644
index 0000000000..b1a2c380ba
--- /dev/null
+++ b/testing/portmidi/03_pm_test_Makefile.patch
@@ -0,0 +1,39 @@
+--- portmidi-20041117.orig/pm_test/debian/Makefile
++++ portmidi-20041117/pm_test/debian/Makefile
+@@ -0,0 +1,36 @@
++# For debugging, define PM_CHECK_ERRORS
++PMFLAGS = -DPM_CHECK_ERRORS
++# Use this for linux alsa (0.9x) version
++ALSALIB = -lasound
++pmlib = -lportmidi
++ptlib = -lporttime
++VFLAGS = -DPMALSA
++
++CC = gcc $(CFLAGS) $(VFLAGS) $(PMFLAGS) -g
++
++all: simple_test sysex midithread latency midithru mm
++
++simple_test: simple_test.o
++ $(CC) simple_test.c -o simple_test $(pmlib) $(ptlib) $(ALSALIB)
++
++sysex: sysex.o
++ $(CC) sysex.c -o sysex $(pmlib) $(ptlib) $(ALSALIB)
++
++midithread: midithread.o
++ $(CC) midithread.c -o midithread \
++ $(pmlib) $(ptlib) $(ALSALIB)
++
++latency: latency.o
++ $(CC) latency.c -o latency $(pmlib) $(ptlib) \
++ $(ALSALIB) -lpthread -lm
++
++midithru: midithru.o
++ $(CC) midithru.c -o midithru $(pmlib) $(ptlib) \
++ $(ALSALIB) -lpthread -lm
++
++mm: mm.o
++ $(CC) mm.c -o mm $(pmlib) $(ptlib) \
++ $(ALSALIB) -lpthread -lm
++
++clean:
++ rm -f *.o mm midithru latency midithread sysex simple_test