aboutsummaryrefslogtreecommitdiffstats
path: root/testing/postfwd
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-21 21:07:33 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-21 21:38:08 -0300
commitd74c0d7b2781c01f740a3e71ec8f5e78a6d99ecb (patch)
tree6e0654e5156b5a720c53631cf27d19689c1cc002 /testing/postfwd
parente83ef14dd7237bb812f7bc842dcedcd3ec367d7b (diff)
downloadaports-d74c0d7b2781c01f740a3e71ec8f5e78a6d99ecb.tar.bz2
aports-d74c0d7b2781c01f740a3e71ec8f5e78a6d99ecb.tar.xz
testing/postfwd: upgrade to 2.02
Diffstat (limited to 'testing/postfwd')
-rw-r--r--testing/postfwd/APKBUILD11
-rw-r--r--testing/postfwd/postfwd.initd23
2 files changed, 16 insertions, 18 deletions
diff --git a/testing/postfwd/APKBUILD b/testing/postfwd/APKBUILD
index 5d9d59ccc9..510c67030b 100644
--- a/testing/postfwd/APKBUILD
+++ b/testing/postfwd/APKBUILD
@@ -1,12 +1,12 @@
# Contributor: Simon Frankenberger <simon-alpine@fraho.eu>
# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
pkgname=postfwd
-pkgver=2.01
+pkgver=2.02
pkgrel=0
pkgdesc="Combines complex postfix restrictions in a ruleset similar to those of the most firewalls"
url="https://postfwd.org/"
arch="noarch"
-license="BSD"
+license="BSD-3-Clause"
depends="perl-net-server perl-net-dns perl-io-multiplex"
subpackages="$pkgname-doc $pkgname-openrc"
source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz
@@ -14,7 +14,6 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$
$pkgname.confd
"
options="!check" # package has no tests
-builddir="$srcdir/$pkgname-$pkgver"
pkgusers="postfwd"
pkggroups="postfwd"
install="$pkgname.pre-install"
@@ -22,13 +21,11 @@ provides="postfwd2=$pkgver-r$pkgrel" # for backward compatibility
replaces="postfwd2" # for backward compatibility
build() {
- cd "$builddir"
# just print out version to check if all dependencies are met
sbin/postfwd -V
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir"/usr/sbin \
"$pkgdir"/usr/share/doc/$pkgname \
"$pkgdir"/usr/share/man/man8 \
@@ -45,6 +42,6 @@ package() {
install -dm750 -o postfwd -g postfwd "$pkgdir"/var/lib/postfw
}
-sha512sums="71433e67ed0da166909cde427847a78e3764439871f17a749c7560e21668a5b89f43f354e2af84a3724dff1c763407e79384eb92ba3334a3515b853262e1556e postfwd-2.01.tar.gz
-d68b1a1a8294fcccc7a2d9d88bb7b93c16569524e6844f17c4a4ad0df0abca17690dc021267e92b10b4a88f8dd21b559d36a9ca8a71e1813ca3819b4a2684d1c postfwd.initd
+sha512sums="1092a3075c3893c39723ec7fe96942effcaa30c97192be8dd9adc6c771849a8a27bc9ea86e0a6ca2ef77812152c158be358c08a2a42cef8116fdacf317d56119 postfwd-2.02.tar.gz
+5c60f1741c174a6b19b00d19edc6f27449e3316844a6ab5c8a46b61f7d52dae0dbdeb495faacb71e2c92cae8c2d82edc89d0c1a79e082b207ee443b9ac976a93 postfwd.initd
3fdd6558eb3d87b8ef05c4e650ea33fcfe5bde412590ab7cb745bc1fdbf62f4f4630da271de59e6300ddd1a77287e084f7f2766c312bc2f82eb98a5623dedac2 postfwd.confd"
diff --git a/testing/postfwd/postfwd.initd b/testing/postfwd/postfwd.initd
index 81d8613a17..80721b81ab 100644
--- a/testing/postfwd/postfwd.initd
+++ b/testing/postfwd/postfwd.initd
@@ -1,18 +1,19 @@
#!/sbin/openrc-run
+supervisor=supervise-daemon
-command="/usr/sbin/postfwd"
-pidfile="/run/postfwd.pid"
+name=postfwd
+description="Postfix firewall daemon"
+
+command=/usr/sbin/postfwd
command_args="--file ${POSTFWD_CONFIG}
---interface=${POSTFWD_LISTEN}
---port=${POSTFWD_PORT}
---user=${POSTFWD_USER}
---group=${POSTFWD_GROUP}
---pidfile ${pidfile}
-${POSTFWD_OPTS}
-"
-command_args_background="--daemon"
+ --interface=${POSTFWD_LISTEN}
+ --port=${POSTFWD_PORT}
+ --user=${POSTFWD_USER}
+ --group=${POSTFWD_GROUP}
+ ${POSTFWD_OPTS}
+ "
+command_args_foreground="--nodaemon"
depend() {
need net
}
-