aboutsummaryrefslogtreecommitdiffstats
path: root/testing/proftpd
diff options
context:
space:
mode:
authorElizabeth Jennifer Myers <elizabeth@sporksirc.net>2011-02-03 08:02:53 +0000
committerElizabeth Jennifer Myers <elizabeth@sporksirc.net>2011-02-03 08:02:53 +0000
commit46f323660247f30243eeae7940562704682630e5 (patch)
treeb6e74b0ece13e5ffbc5d7e66b1449b921bef0908 /testing/proftpd
parent4bd1d1ab34b210ee8abfa7430bd2d49cb91227ba (diff)
downloadaports-46f323660247f30243eeae7940562704682630e5.tar.bz2
aports-46f323660247f30243eeae7940562704682630e5.tar.xz
testing/proftpd: new aport
Diffstat (limited to 'testing/proftpd')
-rw-r--r--testing/proftpd/APKBUILD40
-rw-r--r--testing/proftpd/proftpd.confd7
-rw-r--r--testing/proftpd/proftpd.initd29
3 files changed, 76 insertions, 0 deletions
diff --git a/testing/proftpd/APKBUILD b/testing/proftpd/APKBUILD
new file mode 100644
index 0000000000..b77f36a6d7
--- /dev/null
+++ b/testing/proftpd/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
+# Maintainer: Elizabeth Jennifer Myers <elizabeth@sporksirc.net>
+pkgname=proftpd
+pkgver=1.3.3d
+pkgrel=0
+pkgdesc="Highly configurable GPL-licensed FTP server software"
+url="http://www.proftpd.org/"
+arch="all"
+license="GPLv2"
+depends="openssl gettext ncurses"
+depends_dev="ncurses-dev openssl-dev"
+makedepends="$depends_dev libtool"
+install=""
+subpackages="$pkgname-doc"
+source="ftp://ftp.proftpd.org/distrib/source/proftpd-${pkgver}.tar.bz2"
+
+_builddir="$srcdir"/"$pkgname"-"$pkgver"
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --enable-openssl \
+ --enable-facl \
+ --enable-dso \
+ --enable-ipv6 \
+ --enable-ctrls \
+ --with-modules=mod_quotatab:mod_quotatab_file:mod_tls \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/run
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="69650e91e05b3a10fa3ac54ee261679b proftpd-1.3.3d.tar.bz2"
diff --git a/testing/proftpd/proftpd.confd b/testing/proftpd/proftpd.confd
new file mode 100644
index 0000000000..0cf909c432
--- /dev/null
+++ b/testing/proftpd/proftpd.confd
@@ -0,0 +1,7 @@
+# Sample conf.d file for alpine linux
+
+#
+# Specify daemon options here.
+#
+
+sample_opts="-6"
diff --git a/testing/proftpd/proftpd.initd b/testing/proftpd/proftpd.initd
new file mode 100644
index 0000000000..30aae779c1
--- /dev/null
+++ b/testing/proftpd/proftpd.initd
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+
+# Sample init.d file for alpine linux.
+
+name=proftpd
+daemon=/usr/sbin/proftpd
+
+depend() {
+ need net
+ after firewall
+}
+
+start() {
+ ebegin "Starting ${name}"
+ start-stop-daemon --start --quiet \
+ --pidfile /var/run/${name}.pid \
+ --chuid ${sample_user}:${sample_group} \
+ --exec ${daemon} -- ${sample_opts}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${name}"
+ start-stop-daemon --stop --quiet \
+ --pidfile /var/run/$name.pid \
+ --exec ${daemon}
+ eend $?
+}
+