aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pulseaudio
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-26 11:10:07 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-26 11:10:07 +0200
commita39e19f96447a409ae6f6c1c63d3c16feb1a3991 (patch)
tree148fdebc95bfd8788f91996703d2094c1b8df4da /testing/pulseaudio
parentc5240dc4d2a5efc26b94c943d87848e51ba2794b (diff)
downloadaports-a39e19f96447a409ae6f6c1c63d3c16feb1a3991.tar.bz2
aports-a39e19f96447a409ae6f6c1c63d3c16feb1a3991.tar.xz
unmaintained/[multiple] move back packages to testing
move back packages that are depends of other packages in testing
Diffstat (limited to 'testing/pulseaudio')
-rw-r--r--testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch70
-rw-r--r--testing/pulseaudio/APKBUILD147
-rw-r--r--testing/pulseaudio/pulseaudio.confd7
-rw-r--r--testing/pulseaudio/pulseaudio.initd81
4 files changed, 305 insertions, 0 deletions
diff --git a/testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch b/testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch
new file mode 100644
index 0000000000..22f524313d
--- /dev/null
+++ b/testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch
@@ -0,0 +1,70 @@
+From f6ab3c3aa7a1841c8add04828029356d2a8c88e7 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 6 Apr 2015 21:56:31 -0700
+Subject: [PATCH] padsp: Make it compile on musl
+
+break assumptions on glibc and there is no stat64 on non
+glibc C libraries
+
+See pulseaudio bug
+
+https://bugs.freedesktop.org/show_bug.cgi?id=85319
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/utils/padsp.c | 15 +++++++++------
+ 1 file changed, 9 insertions(+), 6 deletions(-)
+
+diff --git a/src/utils/padsp.c b/src/utils/padsp.c
+index e61373c..684721a 100644
+--- src/utils/padsp.c
++++ src/utils/padsp.c
+@@ -2368,7 +2368,7 @@ fail:
+ return ret;
+ }
+
+-#ifdef sun
++#ifndef __GLIBC__
+ int ioctl(int fd, int request, ...) {
+ #else
+ int ioctl(int fd, unsigned long request, ...) {
+@@ -2508,10 +2508,13 @@ int stat(const char *pathname, struct stat *buf) {
+
+ return 0;
+ }
+-
+ #ifdef HAVE_OPEN64
+-
++#undef stat64
++#ifdef __GLIBC__
+ int stat64(const char *pathname, struct stat64 *buf) {
++#else
++int stat64(const char *pathname, struct stat *buf) {
++#endif
+ struct stat oldbuf;
+ int ret;
+
+@@ -2544,7 +2547,7 @@ int stat64(const char *pathname, struct stat64 *buf) {
+
+ return 0;
+ }
+-
++#undef open64
+ int open64(const char *filename, int flags, ...) {
+ va_list args;
+ mode_t mode = 0;
+@@ -2670,8 +2673,8 @@ FILE* fopen(const char *filename, const char *mode) {
+ }
+
+ #ifdef HAVE_OPEN64
+-
+-FILE *fopen64(const char *filename, const char *mode) {
++#undef fopen64
++FILE *fopen64(const char *__restrict filename, const char *__restrict mode) {
+
+ debug(DEBUG_LEVEL_VERBOSE, __FILE__": fopen64(%s)\n", filename?filename:"NULL");
+
+--
+2.1.4
+
diff --git a/testing/pulseaudio/APKBUILD b/testing/pulseaudio/APKBUILD
new file mode 100644
index 0000000000..8885170df9
--- /dev/null
+++ b/testing/pulseaudio/APKBUILD
@@ -0,0 +1,147 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=pulseaudio
+pkgver=8.0
+pkgrel=0
+pkgdesc="A featureful, general-purpose sound server"
+url="http://www.freedesktop.org/wiki/Software/PulseAudio"
+arch="all"
+license="LGPL"
+depends=""
+depends_dev="libcap-dev json-c-dev libsndfile-dev dbus-dev alsa-lib-dev tdb-dev
+ speexdsp-dev sbc-dev bluez-dev jack-dev avahi-dev openssl-dev eudev-dev"
+makedepends="$depends_dev automake autoconf m4 intltool libtool bash"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bluez
+ $pkgname-alsa $pkgname-utils $pkgname-jack $pkgname-zeroconf $pkgname-system
+ $pkgname-bash-completion:bashcomp $pkgname-zsh-completion:zshcomp"
+source="http://freedesktop.org/software/pulseaudio/releases/pulseaudio-$pkgver.tar.xz
+ 0001-padsp-Make-it-compile-on-musl.patch
+ $pkgname.initd
+ $pkgname.confd"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-bluez4 \
+ --disable-nls \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+}
+
+system() {
+ arch="noarch"
+ depends="$pkgname"
+ pkgdesc="Pulseaudio system-wide init scripts"
+ install -D -m755 "$srcdir"/$pkgname.initd \
+ "$subpkgdir"/etc/init.d/$pkgname || return 1
+ install -D -m644 "$srcdir"/$pkgname.confd \
+ "$subpkgdir"/etc/conf.d/$pkgname || return 1
+ mv "$pkgdir"/etc/dbus-1 "$subpkgdir"/etc
+}
+
+libs() {
+ pkgdesc="Pulseaudio libraries"
+ mkdir -p "$subpkgdir"/usr/lib \
+ "$subpkgdir"/etc/pulse || return 1
+ mv "$pkgdir"/usr/lib/pulseaudio \
+ "$subpkgdir"/usr/lib/ || return 1
+ mv "$pkgdir"/usr/lib/libpulse.so.0* \
+ "$pkgdir"/usr/lib/libpulse-simple.so.0* \
+ "$subpkgdir"/usr/lib/ || return 1
+ mv "$pkgdir"/etc/pulse/client.conf \
+ "$subpkgdir"/etc/pulse/ || return 1
+}
+
+bluez() {
+ pkgdesc="Pulseaudio bluetooth support"
+ mkdir -p "$subpkgdir"/usr/lib/pulse-$pkgver/modules
+ mv "$pkgdir"/usr/lib/pulse-$pkgver/modules/*bluez*.so \
+ "$pkgdir"/usr/lib/pulse-$pkgver/modules/*bluetooth*.so \
+ "$subpkgdir"/usr/lib/pulse-$pkgver/modules/ || return 1
+}
+
+alsa() {
+ pkgdesc="Pulseaudio alsa support"
+ mkdir -p "$subpkgdir"/usr/lib/pulse-$pkgver/modules
+ mv "$pkgdir"/usr/lib/pulse-$pkgver/modules/*alsa*.so \
+ "$subpkgdir"/usr/lib/pulse-$pkgver/modules/ || return 1
+}
+
+utils() {
+ pkgdesc="Pulseaudio utilities"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/pa* \
+ "$pkgdir"/usr/bin/esdcompat \
+ "$subpkgdir"/usr/bin/ || return 1
+}
+
+jack() {
+ pkgdesc="Pulseaudio jack support"
+ mkdir -p "$subpkgdir"/usr/lib/pulse-$pkgver/modules
+ mv "$pkgdir"/usr/lib/pulse-$pkgver/modules/*jack*.so \
+ "$subpkgdir"/usr/lib/pulse-$pkgver/modules/ || return 1
+}
+
+zeroconf() {
+ pkgdesc="Pulseaudio zeroconf support"
+ mkdir -p "$subpkgdir"/usr/lib/pulse-$pkgver/modules
+ mv "$pkgdir"/usr/lib/pulse-$pkgver/modules/*avahi*.so \
+ "$pkgdir"/usr/lib/pulse-$pkgver/modules/*zeroconf*.so \
+ "$pkgdir"/usr/lib/pulse-$pkgver/modules/*raop*.so \
+ "$subpkgdir"/usr/lib/pulse-$pkgver/modules/ || return 1
+}
+
+bashcomp() {
+ pkgdesc="Bash completion for $pkgname"
+ arch="noarch"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel bash-completion"
+ install -dm755 "$subpkgdir"/usr/share || return 1
+ mv "$pkgdir"/usr/share/bash-completion "$subpkgdir"/usr/share
+}
+
+zshcomp() {
+ pkgdesc="Zsh completion for $pkgname"
+ arch="noarch"
+ depends=""
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+ install -dm755 "$subpkgdir"/usr/share || return 1
+ mv "$pkgdir"/usr/share/zsh "$subpkgdir"/usr/share
+}
+
+md5sums="8678442ba0bb4b4c33ac6f62542962df pulseaudio-8.0.tar.xz
+be814e7c1f53062f1a506c71a97dd6cb 0001-padsp-Make-it-compile-on-musl.patch
+884cb9a843361844904e8c85542e72fb pulseaudio.initd
+bf7487ba2c48fc8a56bca41c97a18934 pulseaudio.confd"
+sha256sums="690eefe28633466cfd1ab9d85ebfa9376f6b622deec6bfee5091ac9737cd1989 pulseaudio-8.0.tar.xz
+1c0ffd3a95b4bc65b97bd8bc6cca0fce386cecf2807e96ddd146521b47003004 0001-padsp-Make-it-compile-on-musl.patch
+bbd37d052962ddbf6ae633e4e3896da292d3e916a9123558a9b973096dda842d pulseaudio.initd
+c03661e8cc902d27ff6b52f291207f2b008957571b942abdd92a873a52aae0dd pulseaudio.confd"
+sha512sums="7008abf768f720839353038ffd3e35e442f82452aa7e27d446f75d403096b042643d2b2b1d153454302bd5a51f9217f4979c8995b80ba2695f141e6a29e164fa pulseaudio-8.0.tar.xz
+0542ade084625e278bf1efdf4a72ed282e4876e98a7358d3c2746659ac3cac4098850468447b6018413022ee7dc085ac2ef34cc661d88e1d150a920cfcf79620 0001-padsp-Make-it-compile-on-musl.patch
+34fe54ece5df60ce63a7955cd828a2716670fef71f40960698ae5518fdaf9cd599f4d8f8852e2c88d715600a9ad06a38984415e5eb320071012e5eb6e5c1b8b1 pulseaudio.initd
+75b54581591519d63a3362b155c0f9b0501a60763ab394693a456c44d0216138cf3a40bdd0f7442028663bc045e9ffee286f8f8eaf2ee3bb17379b43615fee0e pulseaudio.confd"
diff --git a/testing/pulseaudio/pulseaudio.confd b/testing/pulseaudio/pulseaudio.confd
new file mode 100644
index 0000000000..1d31d342a0
--- /dev/null
+++ b/testing/pulseaudio/pulseaudio.confd
@@ -0,0 +1,7 @@
+# Config file for /etc/init.d/pulseaudio
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/files/pulseaudio.conf.d,v 1.6 2006/07/29 15:34:18 flameeyes Exp $
+
+# For more see "pulseaudio -h".
+
+# Startup options
+PA_OPTS="--log-target=syslog --disallow-module-loading=1"
diff --git a/testing/pulseaudio/pulseaudio.initd b/testing/pulseaudio/pulseaudio.initd
new file mode 100644
index 0000000000..6dc11bf82b
--- /dev/null
+++ b/testing/pulseaudio/pulseaudio.initd
@@ -0,0 +1,81 @@
+#!/sbin/openrc-run
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/files/pulseaudio.init.d-5,v 1.1 2011/03/27 16:58:49 ssuominen Exp $
+
+depend() {
+ need localmount
+ use net
+
+ local script="/etc/pulse/system.pa"
+
+ for opt in ${PA_OPTS}; do
+ case "$opt" in
+ --file=*) script="${opt#*=}" ;;
+ -F*) script="${opt#-F}" ;;
+ esac
+ done
+
+ config "$script"
+
+ local needs="$(get_options need)"
+ if [ -n "${needs}" ]; then
+ need ${needs}
+ return
+ fi
+
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-console-kit' "$script"; then
+ needs="${needs} consolekit"
+ fi
+
+#ifdef UDEV
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-udev-detect' "$script"; then
+ needs="${needs} udev"
+ fi
+#endif
+
+#ifdef AVAHI
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-zeroconf-publish' "$script"; then
+ needs="${needs} avahi-daemon"
+ fi
+#endif
+
+#ifdef BLUETOOTH
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-bt-proximity' "$script"; then
+ needs="${needs} bluetooth"
+ fi
+#endif
+
+#ifdef ALSA
+ if egrep -q '^[[:space:]]*load-module[[:space:]]+module-alsa-(sink|source)' "$script" ||
+ egrep -q '^[[:space:]]*load-module[[:space:]]+module-(udev-)?detect' "$script" ||
+ egrep -q '^[[:space:]]*add-autoload-source[[:space:]]+(input|output)[[:space:]]+module-alsa-(sink|source)' "$script"; then
+ needs="${needs} alsa" # in Alpine install alsa-utils to provide /etc/init.d/alsa (not alsasound as in Gentoo).
+ fi
+#endif
+
+ need "${needs}"
+ save_options need "${needs}"
+}
+
+start() {
+ if [ -z "${PULSEAUDIO_SHOULD_NOT_GO_SYSTEMWIDE}" ]; then
+ eerror "Please don't use system wide PulseAudio unless you read the"
+ eerror "documentation available at http://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/SystemWide/"
+ eerror ""
+ eerror "When you're done, please set the variable PULSEAUDIO_SHOULD_NOT_GO_SYSTEMWIDE in"
+ eerror "/etc/conf.d/pulseaudio . Please remember that upstream does not support this mode"
+ eerror "when used for standard desktop configurations."
+ return 1
+ fi
+ ebegin "Starting pulseaudio"
+ PA_ALL_OPTS="${PA_OPTS} --fail=1 --daemonize=1 --system"
+ start-stop-daemon --start --exec /usr/bin/pulseaudio -- ${PA_ALL_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping pulseaudio"
+ start-stop-daemon --stop --quiet --exec /usr/bin/pulseaudio --pidfile /var/run/pulse/pid
+ eend $?
+}