aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pulseaudio
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-01-09 17:24:43 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2016-01-09 17:25:18 +0100
commitb4e0b3e34d25da63db7aa9ba3af39f0415e393f1 (patch)
treea2400ba18e2e66ecc3075c88822982fbf2130c63 /testing/pulseaudio
parente1868d85f762d6066af9fdc6427eaa3dc532dd04 (diff)
downloadaports-b4e0b3e34d25da63db7aa9ba3af39f0415e393f1.tar.bz2
aports-b4e0b3e34d25da63db7aa9ba3af39f0415e393f1.tar.xz
testing/pulseaudio: upgrade to 7.1
Diffstat (limited to 'testing/pulseaudio')
-rw-r--r--testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch4
-rw-r--r--testing/pulseaudio/APKBUILD31
-rw-r--r--testing/pulseaudio/musl-fixes.patch48
3 files changed, 68 insertions, 15 deletions
diff --git a/testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch b/testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch
index 85559950e8..22f524313d 100644
--- a/testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch
+++ b/testing/pulseaudio/0001-padsp-Make-it-compile-on-musl.patch
@@ -18,8 +18,8 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
diff --git a/src/utils/padsp.c b/src/utils/padsp.c
index e61373c..684721a 100644
---- a/src/utils/padsp.c
-+++ b/src/utils/padsp.c
+--- src/utils/padsp.c
++++ src/utils/padsp.c
@@ -2368,7 +2368,7 @@ fail:
return ret;
}
diff --git a/testing/pulseaudio/APKBUILD b/testing/pulseaudio/APKBUILD
index c412e9c22c..f38f4e7955 100644
--- a/testing/pulseaudio/APKBUILD
+++ b/testing/pulseaudio/APKBUILD
@@ -1,31 +1,33 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=pulseaudio
-pkgver=6.0
-pkgrel=3
+pkgver=7.1
+pkgrel=0
pkgdesc="A featureful, general-purpose sound server"
url="http://www.freedesktop.org/wiki/Software/PulseAudio"
arch="all"
license="LGPL"
depends=""
depends_dev="libcap-dev json-c-dev libsndfile-dev dbus-dev alsa-lib-dev tdb-dev
- speexdsp-dev sbc-dev bluez-dev jack-dev avahi-dev openssl-dev udev-dev"
-makedepends="$depends_dev m4 intltool libtool"
+ speexdsp-dev sbc-dev bluez-dev jack-dev avahi-dev openssl-dev eudev-dev"
+makedepends="$depends_dev automake autoconf m4 intltool libtool"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-bluez
$pkgname-alsa $pkgname-utils $pkgname-jack $pkgname-zeroconf"
source="http://freedesktop.org/software/pulseaudio/releases/pulseaudio-$pkgver.tar.xz
0001-padsp-Make-it-compile-on-musl.patch
+ musl-fixes.patch
$pkgname.initd
$pkgname.confd"
-_builddir="$srcdir"/pulseaudio-$pkgver
+_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
local i
cd "$_builddir"
for i in $source; do
case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ *.patch) msg $i; patch -p0 -i "$srcdir"/$i || return 1;;
esac
done
}
@@ -38,9 +40,9 @@ build() {
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --infodir=/usr/share/info \
--localstatedir=/var \
--disable-bluez4 \
+ --disable-nls \
|| return 1
make || return 1
}
@@ -105,15 +107,18 @@ zeroconf() {
"$subpkgdir"/usr/lib/pulse-$pkgver/modules/ || return 1
}
-md5sums="b691e83b7434c678dffacfa3a027750e pulseaudio-6.0.tar.xz
-ac9d7f4c6cca22d349aaa7649d47a6e3 0001-padsp-Make-it-compile-on-musl.patch
+md5sums="9d0a9817b632cac8e3f3834d7eb1c99d pulseaudio-7.1.tar.xz
+be814e7c1f53062f1a506c71a97dd6cb 0001-padsp-Make-it-compile-on-musl.patch
+759d77a03f09085bc3e35ef57da8ae5e musl-fixes.patch
884cb9a843361844904e8c85542e72fb pulseaudio.initd
bf7487ba2c48fc8a56bca41c97a18934 pulseaudio.confd"
-sha256sums="b50640e0b80b1607600accfad2e45aabb79d379bf6354c9671efa2065477f6f6 pulseaudio-6.0.tar.xz
-4c4af58f0f5f00230407f71e6ee3fa33b923feb12dfbc5ddad2075ab6a3ed234 0001-padsp-Make-it-compile-on-musl.patch
+sha256sums="e667514a28328f92aceea754a224a0150dddfe7e9a71b4c6d31489220153b9d9 pulseaudio-7.1.tar.xz
+1c0ffd3a95b4bc65b97bd8bc6cca0fce386cecf2807e96ddd146521b47003004 0001-padsp-Make-it-compile-on-musl.patch
+02b5102cb21ed82ab2bfb4ec2875b5e00a28a8e684fd90ad117fc561bff23719 musl-fixes.patch
bbd37d052962ddbf6ae633e4e3896da292d3e916a9123558a9b973096dda842d pulseaudio.initd
c03661e8cc902d27ff6b52f291207f2b008957571b942abdd92a873a52aae0dd pulseaudio.confd"
-sha512sums="4f2293b41c8278047a41be4609a6bc267766874001092a91e785b05d5224fd82810862402942dadbb54bed7f74689779c958ca512666dfe6755d29551583cc2d pulseaudio-6.0.tar.xz
-b120d45ddbfe07b1fbbe821f6b6a515a7970a03577e3335e5961f61cbc2596e5d5924aff9c359dddd64f316e62518cd6641cdc113cb25703b1c81294e625e938 0001-padsp-Make-it-compile-on-musl.patch
+sha512sums="21f621bd76268b9dd6e5be2231b0e779a8e0cfdece44c46c8ac96a4e1d4df52fe5b9791ef95a0909a3c177bbfa5eab7d52fed9b43362840a9c8a6001e821175e pulseaudio-7.1.tar.xz
+0542ade084625e278bf1efdf4a72ed282e4876e98a7358d3c2746659ac3cac4098850468447b6018413022ee7dc085ac2ef34cc661d88e1d150a920cfcf79620 0001-padsp-Make-it-compile-on-musl.patch
+4cd3b23b7b71135425d04bf53405a05825b616348e1468cb0f711299a2ec87aabc87721a1d8ca03c63e045879acea1b25d9f795a277dc72cd7031ad7b407e7e6 musl-fixes.patch
34fe54ece5df60ce63a7955cd828a2716670fef71f40960698ae5518fdaf9cd599f4d8f8852e2c88d715600a9ad06a38984415e5eb320071012e5eb6e5c1b8b1 pulseaudio.initd
75b54581591519d63a3362b155c0f9b0501a60763ab394693a456c44d0216138cf3a40bdd0f7442028663bc045e9ffee286f8f8eaf2ee3bb17379b43615fee0e pulseaudio.confd"
diff --git a/testing/pulseaudio/musl-fixes.patch b/testing/pulseaudio/musl-fixes.patch
new file mode 100644
index 0000000000..db5ed86871
--- /dev/null
+++ b/testing/pulseaudio/musl-fixes.patch
@@ -0,0 +1,48 @@
+Portability fixes for musl taken from voidlinux:
+
+- _WORDIZE is declared in <bits/user.h> via <sys/user.h>.
+- <xlocale.h> does not exist, check for it correctly.
+
+ --xtraeme
+
+--- configure.ac.orig 2015-09-24 11:36:06.107661526 +0200
++++ configure.ac 2015-09-24 11:36:40.420036775 +0200
+@@ -407,7 +407,7 @@ AC_HEADER_STDC
+ # POSIX
+ AC_CHECK_HEADERS_ONCE([arpa/inet.h glob.h grp.h netdb.h netinet/in.h \
+ netinet/in_systm.h netinet/tcp.h poll.h pwd.h sched.h \
+- sys/mman.h sys/select.h sys/socket.h sys/wait.h \
++ sys/mman.h sys/select.h sys/socket.h sys/wait.h sys/user.h xlocale.h \
+ sys/uio.h syslog.h sys/dl.h dlfcn.h linux/sockios.h])
+ AC_CHECK_HEADERS([netinet/ip.h], [], [],
+ [#include <sys/types.h>
+--- src/pulsecore/sample-util.h.orig 2015-09-24 11:37:57.773677238 +0200
++++ src/pulsecore/sample-util.h 2015-09-24 11:38:46.668208677 +0200
+@@ -24,6 +24,14 @@
+ #include <inttypes.h>
+ #include <limits.h>
+
++#ifdef HAVE_CONFIG_H
++#include <config.h>
++#endif
++
++#ifdef HAVE_SYS_USER_H
++#include <sys/user.h> /* required by _WORDIZE with musl */
++#endif
++
+ #include <pulse/gccmacro.h>
+ #include <pulse/sample.h>
+ #include <pulse/volume.h>
+--- src/pulsecore/core-util.c.orig 2015-09-24 11:45:57.919919956 +0200
++++ src/pulsecore/core-util.c 2015-09-24 11:46:23.343196284 +0200
+@@ -54,7 +54,9 @@
+
+ #ifdef HAVE_STRTOD_L
+ #include <locale.h>
+-#include <xlocale.h>
++# ifdef HAVE_XLOCALE_H
++# include <xlocale.h>
++# endif
+ #endif
+
+ #ifdef HAVE_SCHED_H