aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-argcomplete
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-11-08 13:13:56 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2017-12-01 08:57:41 +0100
commite21ce1fa3cec1f917d9a5b5da9cbeae4d07c4212 (patch)
tree4fe81b3c029283f7052861712454bf81c0ad4688 /testing/py-argcomplete
parent420d75883aebbe3326b1d12d582e916986af8d16 (diff)
downloadaports-e21ce1fa3cec1f917d9a5b5da9cbeae4d07c4212.tar.bz2
aports-e21ce1fa3cec1f917d9a5b5da9cbeae4d07c4212.tar.xz
testing/py-argcomplete: new aport
Diffstat (limited to 'testing/py-argcomplete')
-rw-r--r--testing/py-argcomplete/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/py-argcomplete/APKBUILD b/testing/py-argcomplete/APKBUILD
new file mode 100644
index 0000000000..ad871a0dda
--- /dev/null
+++ b/testing/py-argcomplete/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=py-argcomplete
+_pkgname=${pkgname#py-}
+pkgver=1.9.2
+pkgrel=0
+pkgdesc="Easy, extensible command line tab completion of arguments for your Python script"
+url="https://github.com/kislyuk/argcomplete"
+arch="noarch"
+license="ASL 2.0"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kislyuk/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr \
+ --root="$subpkgdir" --optimize=1
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="0af5c78045e5f513dab475b665150ee2bf67d66c306046753d80925398040d7c537381c5f89ffe83872dbd711012bbad0e610c57e37f5234ef51470b63a9da4d py-argcomplete-1.9.2.tar.gz"