aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-bandwidth-sdk
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 03:12:59 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-08-15 03:12:59 +0000
commit5b5ff813d9486f297a3e9abd3ca9ba2a5cf8e6c6 (patch)
treeca16ebea365968f9a5eb8d028bd5dcb0167745ea /testing/py-bandwidth-sdk
parent9b86bcecaf90460c6fab3464a4d42909a4700375 (diff)
downloadaports-5b5ff813d9486f297a3e9abd3ca9ba2a5cf8e6c6.tar.bz2
aports-5b5ff813d9486f297a3e9abd3ca9ba2a5cf8e6c6.tar.xz
testing/py-bandwidth-sdk: new aport
Diffstat (limited to 'testing/py-bandwidth-sdk')
-rw-r--r--testing/py-bandwidth-sdk/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/testing/py-bandwidth-sdk/APKBUILD b/testing/py-bandwidth-sdk/APKBUILD
new file mode 100644
index 0000000000..6eef3ba82e
--- /dev/null
+++ b/testing/py-bandwidth-sdk/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=py-bandwidth-sdk
+pkgver=3.0.0b0
+pkgrel=0
+pkgdesc="python helpers for using bandwidth.com API"
+url="https://pypi.python.org/pypi/bandwidth-sdk/"
+arch="noarch"
+license="BSD"
+depends="py-requests"
+makedepends="python2-dev python3-dev py-setuptools"
+install=""
+subpackages="py2-bandwidth-sdk:py2 py3-bandwidth-sdk:py3"
+source="https://files.pythonhosted.org/packages/source/b/bandwidth-sdk/bandwidth_sdk-$pkgver.tar.gz"
+builddir="$srcdir/bandwidth_sdk-$pkgver"
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc ${python#python}"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+py2() {
+ cd "$builddir"
+ _py python2
+}
+
+py3() {
+ cd "$builddir"
+ _py python3
+}
+
+sha512sums="9cd6528dded5a9f080360191881083bb74220336a6a8b33bcee50f81031089f114497801d9cb8e4f25c90d288a429fa54f3d15d10cc001bee0259054c0586060 bandwidth_sdk-3.0.0b0.tar.gz"