aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-bottle-request
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-10-05 12:59:37 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 08:23:14 +0000
commit00c04a9efdd11a152831385921f9b2a194b6c6f7 (patch)
treebf56c2f076995a101a1d3b611d92b942310f5182 /testing/py-bottle-request
parent478de1e9db0040c1f7d021d0f27dfa9a80df819b (diff)
downloadaports-00c04a9efdd11a152831385921f9b2a194b6c6f7.tar.bz2
aports-00c04a9efdd11a152831385921f9b2a194b6c6f7.tar.xz
testing/py-bottle-request: new aport
Bottle 'stateless' request object plugin http://github.com/turtlebender/bottle-request/
Diffstat (limited to 'testing/py-bottle-request')
-rw-r--r--testing/py-bottle-request/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-bottle-request/APKBUILD b/testing/py-bottle-request/APKBUILD
new file mode 100644
index 0000000000..b90f01dc82
--- /dev/null
+++ b/testing/py-bottle-request/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-bottle-request
+_pkgname=bottle-request
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="Bottle 'stateless' request object plugin"
+url="http://github.com/turtlebender/bottle-request/"
+arch="noarch"
+license="MIT"
+depends="python py-bottle"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="4da8d6bfebf4a9a80b70948cbd234dc7 bottle-request-0.2.0.tar.gz"
+sha256sums="e41f764dd7ea94eb4a65d492e354eac0500123d15c2a80bc6582ea8a793bf84f bottle-request-0.2.0.tar.gz"
+sha512sums="bd12268d703996e200dea5817f939ecf80e572e97d3686bcaf988ec048cda4e3b950122588b91ce78a06712a321e155e2e365bc75bbd2a720228a65441a67e21 bottle-request-0.2.0.tar.gz"